Qbittorrent font size does no respect my system's preferences

Linux specific questions, problems.

Moderators: Moderator, Global Moderator

Post Reply
michaelgr
Newbie
Newbie
Posts: 4
Joined: Fri Mar 10, 2017 1:43 pm

Qbittorrent font size does no respect my system's preferences

Post by michaelgr » Sat Oct 19, 2019 2:47 pm

I know it says "Don't report bugs" but I'm not sure this is a bug yet.
I'm on Mint 19.2 and Qbittorrent's 4.18, and QB's UI doesn't seem to respect wither the system font size I had set (14pt) or the OS theme.
You can see the issue in the attached file.

For starters, I just want to know, is this what everyone is experiencing or is this some glitch on my system specifically?
And if this is a universal thing, is there a way to change/fix the issue and make QB use the OS theme and font sizes?
Attachments
qb.png

Drugwash
Newbie
Newbie
Posts: 7
Joined: Wed Jul 24, 2019 8:23 am

Re: Qbittorrent font size does no respect my system's preferences

Post by Drugwash » Mon Nov 04, 2019 11:31 am

This application uses a Qt5 GUI so you'd have to launch the Qt5 Settings GUI (Qt5 Configuration Tool) and make your changes there.
If it's not installed then launch Software Manager, search for Qt5ct and install it.

michaelgr
Newbie
Newbie
Posts: 4
Joined: Fri Mar 10, 2017 1:43 pm

Re: Qbittorrent font size does no respect my system's preferences

Post by michaelgr » Fri Nov 15, 2019 8:25 am

This application uses a Qt5 GUI so you'd have to launch the Qt5 Settings GUI (Qt5 Configuration Tool) and make your changes there.
If it's not installed then launch Software Manager, search for Qt5ct and install it.
Thank you! There were some extra complications - when trying to run QT5 settings there was an error message:
QT_QPA_PLATFORMTHEME environment variable is not set correctly

I was able to find the solution for that as well and change the fonts.
For future reference here are the complete instructions:

1. Install qt5ct
2. install qt5-styleplugins
3. edit (using sudo and your favorite editor) /etc/environment
4. add in a new line: QT_QPA_PLATFORMTHEME=qt5ct
5. Restart

to make Qbittorrent look like Mint use the following settings:
style - gtk2
font - Noto sans regular
icon theme - Mint-y

michaelgr
Newbie
Newbie
Posts: 4
Joined: Fri Mar 10, 2017 1:43 pm

Re: Qbittorrent font size does no respect my system's preferences

Post by michaelgr » Fri Nov 15, 2019 11:01 am

thanks!

there were some further complications with some error message, but I found a solution and got it to work.

for the record, I also had to install qt5-styleplugins,
and edit /etc/environment and add the following line:
QT_QPA_PLATFORMTHEME=qt5ct

Drugwash
Newbie
Newbie
Posts: 7
Joined: Wed Jul 24, 2019 8:23 am

Re: Qbittorrent font size does no respect my system's preferences

Post by Drugwash » Mon Nov 18, 2019 11:21 am

Glad you got it working.
There was no such error here so didn't have to manually edit the environment file; looking into it now there's only a PATH string there, nothing more.

Post Reply