[unofficial]qBittorrent git master builds: 3.1.0RC_06102013

Testing the freshly baked, latest builds!

Moderator: Global Moderator

Splat
Member
Member
Posts: 61
Joined: Wed Sep 28, 2011 1:36 am

Re: [unofficial]qBittorrent git master builds: 3.1.0alpha19092013

Post by Splat » Tue Sep 24, 2013 11:34 pm

I d/l the latest build yesterday and noticed something weird. I had never gotten this msg on DIME using older versions of qB but now I see for "firewalled ports" under my DIME profile this msg "no/erroneous BT client listening or misconfigured router".  I've changed absolutely nothing in my router and still using the same forwarded port as before so I've no clue why I'm seeing this now. I can d/l and u/l fine, though the u/l speeds do appear to be slow but I cannot officially confirm that is qbittorrent_3.1.0alpha_19092013's fault.

alfrix
Member
Member
Posts: 21
Joined: Tue Apr 23, 2013 4:07 pm

Re: [unofficial]qBittorrent git master builds: 3.1.0alpha19092013

Post by alfrix » Wed Sep 25, 2013 3:18 am

[quote="sledgehammer_999"]
Since I don't know the real cause of the problem, I just have to re-write how each torrent's status gets saved. Something like this: https://github.com/qbittorrent/qBittorrent/issues/583
However, this requires A LOT of careful work. TorrentPersistentData is used all over the place. It's not an easy task to undertake. So no ETA unfortunately.
[/quote]

i'm glad that you are aware of it, i hope you can fix this annoying bug, thanks sledge

sledgehammer_999
Administrator
Administrator
Posts: 2406
Joined: Sun Jan 23, 2011 1:17 pm

Re: [unofficial]qBittorrent git master builds: 3.1.0alpha19092013

Post by sledgehammer_999 » Tue Oct 01, 2013 12:33 am

Here is a new alpha build of latest git master -> http://builds.shiki.hu/qbittorrent_3.1. ... _setup.exe

Hot new bugfix: All problems with qbt forgeting savepaths/labels/torrent settings should be gone now. (tomorrow I'll start cleaning up the bug tracker. If I miss something tag me on github and I'll close it)
Also, the execution log is a little bit more verbose when listening to the port speficied. This may help troubleshoot "stalled torrents" problem.

User avatar
Nemo
Administrator
Administrator
Posts: 1518
Joined: Sat Jul 24, 2010 6:24 pm

Re: [unofficial]qBittorrent git master builds: 3.1.0alpha19092013

Post by Nemo » Tue Oct 01, 2013 5:51 pm

Thanks sledge, getting this one.

EDIT: This is what I was saying before with my older posts:

http://i.imgur.com/CCbvnfJ.png

Enough peers but all uploading very low, changed global connections from default 500 to 450 (was just a try) fixed it and my speed went full again. Then went back to 500 and now it works as normal. My settings are always 500 global and 150 per torrent, working since the very beginning. I must add that I never had any issues before with any qBittorrent, but it works now so ill wait till it happens again (hope not) and go back to 3.0.11.
Last edited by Nemo on Tue Oct 01, 2013 6:50 pm, edited 1 time in total.
Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.


Image
Image

sledgehammer_999
Administrator
Administrator
Posts: 2406
Joined: Sun Jan 23, 2011 1:17 pm

Re: [unofficial]qBittorrent git master builds: 3.1.0alpha19092013

Post by sledgehammer_999 » Tue Oct 01, 2013 7:31 pm

I hope you mean "upload slots". The other connections affect download mostly

User avatar
Nemo
Administrator
Administrator
Posts: 1518
Joined: Sat Jul 24, 2010 6:24 pm

Re: [unofficial]qBittorrent git master builds: 3.1.0alpha19092013

Post by Nemo » Wed Oct 02, 2013 4:44 pm

I mean the first torrent on that screenshot, im downloading at very low speed for no reason (all peers uploading to me with low speeds) but changing the above setting made it somehow fix it but its random. I thought it was something like a huge lag or overload which I never had before with any client. Or reserving disk space but also this shouldn't take that much time like im used to be like any other builds. This is the second time im having this, with the previous alpha I had this too sometimes. As you can see its not a popular torrent with only 16 seeds and few leechers so there shouldn't be any problem concerning lag of any kind.

Im having huge speed issues with download and upload speeds with the 2 latest alphas, switching back to 3.0.11 and its gone. Im almost thinking that something is limiting my speeds within the alpha.

Im trying few things out myself; I disabled ''Global maximum number of upload slots'' setting to see how that goes. And lowered the connections, but im very sure thats not the problem. BitSpirit (I know, bad client) was set at 360 connections per torrent back in the days :P! Tried clean installs (something what I always do) still no luck.
Last edited by Nemo on Wed Oct 02, 2013 5:47 pm, edited 1 time in total.
Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.


Image
Image

sledgehammer_999
Administrator
Administrator
Posts: 2406
Joined: Sun Jan 23, 2011 1:17 pm

Re: [unofficial]qBittorrent git master builds: 3.1.0alpha19092013

Post by sledgehammer_999 » Thu Oct 03, 2013 9:07 pm

OK, I'll provide a git master build with libtorrent 0.16.11 instead. If I don't, ping me again.

User avatar
Nemo
Administrator
Administrator
Posts: 1518
Joined: Sat Jul 24, 2010 6:24 pm

Re: [unofficial]qBittorrent git master builds: 3.1.0alpha19092013

Post by Nemo » Sat Oct 05, 2013 12:20 am

Thanks, take your time :). Im not a big fan of alpha builds but want to see the changes and improvments as well :P. I will test current alpha again to be sure. Running 3.0.11 now 2 days and its very stable as always.
Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.


Image
Image

AsaRossoff
Member
Member
Posts: 65
Joined: Thu Jul 11, 2013 12:20 am

Re: [unofficial]qBittorrent git master builds: 3.1.0alpha19092013

Post by AsaRossoff » Sun Oct 06, 2013 5:42 am

Thanks Sledge.  I'll try the latest :)
You do a lot of great work.. appreciated of you and all the contributors.

I have not been using BT of any kind for a bit but as soon as I do I'll comment on bugs I'm on if there is a status update or you requested one.  Just downloaded your oct 1st build. peace and gratitude :)
-asa
p.s. 3rd time's the  charm w/ the verification image to post! ;)

sledgehammer_999
Administrator
Administrator
Posts: 2406
Joined: Sun Jan 23, 2011 1:17 pm

Re: [unofficial]qBittorrent git master builds: 3.1.0alpha19092013

Post by sledgehammer_999 » Sun Oct 06, 2013 11:57 am

Here is the v3.1.0 RC -> http://builds.shiki.hu/qbittorrent_3.1. ... _setup.exe

I want you to try and break the "load magnet metadata in the background" feature. If you notice any UI inconsistence during metadata loading(ie wrong queue numbers), please notify me.

This is a Release Candidate for v3.1.0. I am to release v3.1.0 stable either midweek(Wednesday) or in the weekend. All that's missing is updating the changelog and merging the translations from Transifex.

User avatar
Nemo
Administrator
Administrator
Posts: 1518
Joined: Sat Jul 24, 2010 6:24 pm

Re: [unofficial]qBittorrent git master builds: 3.1.0RC_06102013

Post by Nemo » Sun Oct 06, 2013 2:05 pm

Thanks, sledge & Dayman rocks! Installing :).

Edit: Why is this happening? while 3.0.11 is going with better speeds instead of 2-3-4KB/s. It goes good for a while and then randomly dropping speeds. Also am I the only one experiencing this? I tried uTorrent 2.2.1 to be sure that it isn't my connection (3.0.11 works so I was 99% sure) and its all normal. I can almost say that this only happens with the new alpha's.
Image
Last edited by Nemo on Sun Oct 06, 2013 4:14 pm, edited 1 time in total.
Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.


Image
Image

sledgehammer_999
Administrator
Administrator
Posts: 2406
Joined: Sun Jan 23, 2011 1:17 pm

Re: [unofficial]qBittorrent git master builds: 3.1.0RC_06102013

Post by sledgehammer_999 » Sun Oct 06, 2013 5:07 pm

IIRC 3.0.11 was build against libtorrent 0.16.11 while the RC was build against RC_0_16(don't remember exact rev).
I'll provide you with an RC+0.16.11 to test.

User avatar
Nemo
Administrator
Administrator
Posts: 1518
Joined: Sat Jul 24, 2010 6:24 pm

Re: [unofficial]qBittorrent git master builds: 3.1.0RC_06102013

Post by Nemo » Sun Oct 06, 2013 7:10 pm

I don't know why (lol..seriously) but somehow now it works like it should. Different torrent this time but ill load up the other one too after this.

Image
Last edited by Nemo on Mon Oct 07, 2013 5:43 pm, edited 1 time in total.
Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.


Image
Image

Big_Iron

Re: [unofficial]qBittorrent git master builds: 3.1.0RC_06102013

Post by Big_Iron » Mon Oct 07, 2013 1:31 pm

Download directory bug in the RC version. It's downloading files in multiple folders at main system hdd, even in the Firefox directory (...) but not in the one selected into qbit' configuration options, very strange. Previous version was just working fine, i returned to the stable 3.0.11 in the end and its ok.

sledgehammer_999
Administrator
Administrator
Posts: 2406
Joined: Sun Jan 23, 2011 1:17 pm

Re: [unofficial]qBittorrent git master builds: 3.1.0RC_06102013

Post by sledgehammer_999 » Mon Oct 07, 2013 2:38 pm

Download directory bug in the RC version. It's downloading files in multiple folders at main system hdd, even in the Firefox directory (...) but not in the one selected into qbit' configuration options, very strange. Previous version was just working fine, i returned to the stable 3.0.11 in the end and its ok.
What did you try to download? A magnet or a .torrent? Have you enabled to save incomplete torrents in a separate folder by any chance? Which system folders? Are they selected randomly?
Can you give an example on how to reproduce this?(with settings and steps). I cannot reproduce currently on my system.

Post Reply