[official]qBittorrent 3.3.16 installer - Built with MSVC 2017

Testing the freshly baked, latest builds!

Moderator: Global Moderator

Post Reply
sledgehammer_999
Administrator
Administrator
Posts: 2406
Joined: Sun Jan 23, 2011 1:17 pm

[official]qBittorrent 3.3.16 installer - Built with MSVC 2017

Post by sledgehammer_999 » Sun Nov 29, 2015 9:57 pm

Link to 3.3.16 post-> index.php/topic,3982.msg26056.html#msg26056






*****ORIGINAL POST BELOW****



Here is qBittorrent 3.3.0 built with MSVC 2013 express.

3.3.0 link-> http://www.fosshub.com/qBittorrent.html
Changelog: http://www.qbittorrent.org/news.php

Libraries's version used:
Libtorrent: 1.0.7 (final)
Qt: 5.5.1
Boost: 1.59.0

Small number of changes since RC. See here.
Last edited by sledgehammer_999 on Thu Sep 07, 2017 11:08 pm, edited 1 time in total.

User avatar
Nemo
Administrator
Administrator
Posts: 1518
Joined: Sat Jul 24, 2010 6:24 pm

Re: [official]qBittorrent 3.3.0 installer - Built with MSVC 2013

Post by Nemo » Sun Nov 29, 2015 10:04 pm

Thanks alot sledge and everyone at Github who put their time, effort and work into it making it possible for such a great release.
Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.


Image
Image

tekko

Re: [official]qBittorrent 3.3.0 installer - Built with MSVC 2013

Post by tekko » Mon Nov 30, 2015 2:59 am

For the "missing file" thing, does it fix old affected resume files? or do I have to remove and re-add all torrents to create new ones?
If I understood the problem correctly... The completed torrents can actually be incomplete/corrupted if the bug has occured. It didn't matter if you manually rechecked or not, it will go to 100% anyway.
I have been quite updated with the 3.3.0 alpha/beta releases, so I want to know if my completed and removed torrents can actually be corrupted...

tekko

Re: [official]qBittorrent 3.3.0 installer - Built with MSVC 2013

Post by tekko » Mon Nov 30, 2015 5:34 am

Re-added my whole list and rechecking them. A few torrents became 0% and "queued for checking" again right after the "checking" state. They are previewable, so they're not 0% for sure. I have a long list and still checking. I'm rushing to leave this comment because I think you might want to take it down as a stable release until further testings are done.
Last edited by tekko on Mon Nov 30, 2015 5:54 am, edited 1 time in total.

sledgehammer_999
Administrator
Administrator
Posts: 2406
Joined: Sun Jan 23, 2011 1:17 pm

Re: [official]qBittorrent 3.3.0 installer - Built with MSVC 2013

Post by sledgehammer_999 » Mon Nov 30, 2015 12:55 pm

The issue about "missing files" that I fixed is something else. I don't know what you had. Your best option is to recheck the torrents and after that the status should be much more stable.
If you still have problems, describe it more and with screenshots.

fusk
Veteran
Veteran
Posts: 250
Joined: Sun Feb 23, 2014 1:39 am

Re: [official]qBittorrent 3.3.0 installer - Built with MSVC 2013

Post by fusk » Mon Nov 30, 2015 1:21 pm

Seems like the temp drive bug is still present.
Where using a temp drive makes qbit copy every download back onto the temp drive when windows starts.
So qbit first downloads to temp, then moves to destination. After computer restart it will copy from destination back to temp drive. Even tho save path is not the temp drive. It does not recheck the torrents, just moves them.

Maybe i should post this on github.

tekko

Re: [official]qBittorrent 3.3.0 installer - Built with MSVC 2013

Post by tekko » Mon Nov 30, 2015 3:46 pm

[quote="sledgehammer_999"]
The issue about "missing files" that I fixed is something else. I don't know what you had. Your best option is to recheck the torrents and after that the status should be much more stable.
If you still have problems, describe it more and with screenshots.
[/quote]

The whole list finished checking anyway at the end. i.e. After the rest of the list is rechecked, it went back and checked the ones that were queued again.

I was asking about the "missing files" status because I saw this => https://github.com/qbittorrent/qBittorrent/issues/3602.

I did swap drives with 3.3.0 pre-stables, and I saw the "missing files" status; therefore, I was worried about the torrents I completed and removed were actually corrupted. Even though I "forced recheck" them at least once before removing, it seems that the completed payload still can be corrupted and show 100%?

I don't have connection problems like the others though.
Last edited by tekko on Mon Nov 30, 2015 4:27 pm, edited 1 time in total.

sledgehammer_999
Administrator
Administrator
Posts: 2406
Joined: Sun Jan 23, 2011 1:17 pm

Re: [official]qBittorrent 3.3.0 installer - Built with MSVC 2013

Post by sledgehammer_999 » Mon Nov 30, 2015 4:22 pm

You are confusing me. What are you seeing now? What is the problem now?(if you have any)

tekko

Re: [official]qBittorrent 3.3.0 installer - Built with MSVC 2013

Post by tekko » Mon Nov 30, 2015 4:27 pm

[quote="sledgehammer_999"]
You are confusing me. What are you seeing now? What is the problem now?(if you have any)
[/quote]

I don't quite understand about the "overwriting". If qbt is just redownloading the completed parts, then nothing should be corrupted right? i.e. only bandwidth was wasted?

sledgehammer_999
Administrator
Administrator
Posts: 2406
Joined: Sun Jan 23, 2011 1:17 pm

Re: [official]qBittorrent 3.3.0 installer - Built with MSVC 2013

Post by sledgehammer_999 » Mon Nov 30, 2015 4:31 pm

[quote="tekko"]
[quote="sledgehammer_999"]
You are confusing me. What are you seeing now? What is the problem now?(if you have any)
[/quote]

I don't quite understand about the "overwriting". If qbt is just redownloading the completed parts, then nothing should be corrupted right? i.e. only bandwidth was wasted?
[/quote]

I still don't understand if you have a problem and what problem that is. Assume that you are reporting this for the first time.

tekko

Re: [official]qBittorrent 3.3.0 installer - Built with MSVC 2013

Post by tekko » Mon Nov 30, 2015 4:36 pm

Nevermind. I was just trying to understand the bug that was reported and see if my downloads were corrupted in some way.

Sorry about the confusion.

sledgehammer_999
Administrator
Administrator
Posts: 2406
Joined: Sun Jan 23, 2011 1:17 pm

Re: [official]qBittorrent 3.3.0 installer - Built with MSVC 2013

Post by sledgehammer_999 » Mon Nov 30, 2015 5:21 pm

Then I assume you don't have a problem now, correct?
The bug you linked wasn't followed up by the reporter. However, I found 2 cases where the .fastresume would be incorrectly overwritten when the files were actually missing. After a restart even if they appeared qbt had stored the new (and empty) status of the torrents and begun redownloading.

tekko

Re: [official]qBittorrent 3.3.0 installer - Built with MSVC 2013

Post by tekko » Mon Nov 30, 2015 5:29 pm

[quote="sledgehammer_999"]
Then I assume you don't have a problem now, correct?
The bug you linked wasn't followed up by the reporter. However, I found 2 cases where the .fastresume would be incorrectly overwritten when the files were actually missing. After a restart even if they appeared qbt had stored the new (and empty) status of the torrents and begun redownloading.
[/quote]

Yes, no problem. Thanks.

User avatar
Nemo
Administrator
Administrator
Posts: 1518
Joined: Sat Jul 24, 2010 6:24 pm

Re: [official]qBittorrent 3.3.0 installer - Built with MSVC 2013

Post by Nemo » Tue Dec 01, 2015 7:16 pm

Very stable so far, im happy with its performance.

I've been using Dayman's builds with Qt5 before without any issues also.
Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.


Image
Image

zava
Newbie
Newbie
Posts: 17
Joined: Tue Apr 05, 2011 11:01 am

Re: [official]qBittorrent 3.3.0 installer - Built with MSVC 2013

Post by zava » Thu Dec 03, 2015 10:05 am

Excellent work, perfect stability (Win 7 x64 machine).

Post Reply