Author Topic: Unofficial 64-bit installer/archive 3.3.x  (Read 112013 times)

Nemo

  • qBittorrent Forum
  • Administrator
  • Forum addict
  • *****
  • Posts: 1397
  • Karma: +87/-0
    • View Profile
Re: Unofficial 64-bit installer/archive 3.3.x
« Reply #315 on: June 30, 2017, 01:29:49 am »
Its using huge amount of memory with libtorrent 1.1 with only 2 torrents loaded compared to the other one with 25 torrents (the one im using currently).

I've tested with the 2 same torrents see the results.

qBittorrent v3.3.13 64Bit with libtorrent 1.1 (Dayman's build):


qBittorrent v3.3.13 64Bit with libtorrent 1.0 (Sledge's build):
« Last Edit: June 30, 2017, 01:40:33 am by Nemo »
Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.




Switeck

  • Forum addict
  • ****
  • Posts: 895
  • Karma: +57/-0
    • View Profile
Re: Unofficial 64-bit installer/archive 3.3.x
« Reply #316 on: June 30, 2017, 04:10:37 am »
Could it be the case that libtorrent 1.1 just uses more of the read/write cache by default?
...Or the memory leak with read/write cache is worse?

Nemo

  • qBittorrent Forum
  • Administrator
  • Forum addict
  • *****
  • Posts: 1397
  • Karma: +87/-0
    • View Profile
Re: Unofficial 64-bit installer/archive 3.3.x
« Reply #317 on: July 01, 2017, 01:23:25 am »
Im wondering whats causing this so I opened an issue at Github. Lets see what the devs have to say about it :).

https://github.com/qbittorrent/qBittorrent/issues/7029

Maybe its one of the known issues in combination with qBittorrent and could be the reason why its not being used as the main libtorrent version.
Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.




otis

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Unofficial 64-bit installer/archive 3.3.x
« Reply #318 on: July 13, 2017, 03:05:40 am »
i'm using qBittorrent v3.3.13 64Bit with libtorrent 1.1, I don't know much about testing qbitorrent or any client but I am using 1,230 mb of memory. I have 32 gb so I don't care because it's working good. I just switched from utorrent last night, sick of disk overload and ads from utorrent. I tried to switch to qbittorrent a few months ago and for some reason I wasn't uploading as much with qbittorrent and couldn't figure out why so I went back to utorrent. I figured i'd give it another try and all is good. I don't know what's different lol. anyway i'll provide whatever is needed to help test it or whatever if you tell me what to do. obviously I hope the memory usage gets fixed in the future but i'm still happy with the program. by the way I have 25 torrents running, 1 downloading at 10-20 kb. let me know what info you guys need.

Nemo

  • qBittorrent Forum
  • Administrator
  • Forum addict
  • *****
  • Posts: 1397
  • Karma: +87/-0
    • View Profile
Re: Unofficial 64-bit installer/archive 3.3.x
« Reply #319 on: July 14, 2017, 02:08:09 am »
Thats huge memory usage lol.

Seems like a memory leak specific to libtorrent 1.1 or something.
Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.




sledgehammer_999

  • qBittorrent maintainer
  • Administrator
  • Forum addict
  • *****
  • Posts: 2365
  • Karma: +145/-1
    • View Profile
Re: Unofficial 64-bit installer/archive 3.3.x
« Reply #320 on: July 20, 2017, 02:05:32 am »
Discovered this by chance.
I also am observing huge memory usage with the 1.1.x series on Windows. If I limit the cache in the advanced settings it seems to affect it but not by much.
And it is my intention to use 1.1.x for the upcoming v3.4.0 series.

Nemo

  • qBittorrent Forum
  • Administrator
  • Forum addict
  • *****
  • Posts: 1397
  • Karma: +87/-0
    • View Profile
Re: Unofficial 64-bit installer/archive 3.3.x
« Reply #321 on: July 20, 2017, 02:10:26 am »
Yes, usage over 1GB of memory while idling 2 torrents or so after some time has passed. Fresh startup climbs very fast over 200MB out of nothing while doing nothing. Thats some huge leak. Otherwise it works very nice.

I can help if testing is needed just let me know.

Edit:

Quote
Could possibly be happening on Linux as well. After going back to libtorrent 1.0 the problem went away.

https://github.com/qbittorrent/qBittorrent/issues/5836

Most likely libtorrent 1.1 related then.

« Last Edit: July 20, 2017, 02:14:24 am by Nemo »
Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.