Author Topic: [unofficial]qBittorrent git master builds: 3.1.0RC_06102013  (Read 53775 times)

Nemo

  • qBittorrent Forum
  • Administrator
  • Forum addict
  • *****
  • Posts: 1477
  • Karma: +93/-0
    • View Profile
Re: [unofficial]qBittorrent git master builds: 3.1.0alpha01092013
« Reply #105 on: September 09, 2013, 10:35:33 pm »
I've got a weird bug; All peers are at 99.9%, also the availability bar shows this, but when you look into the peers tab they are shown 100% which is incorrect. Seeds number is also at 0.
Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.




sledgehammer_999

  • qBittorrent maintainer
  • Administrator
  • Forum addict
  • *****
  • Posts: 2406
  • Karma: +150/-2
    • View Profile
Re: [unofficial]qBittorrent git master builds: 3.1.0alpha01092013
« Reply #106 on: September 09, 2013, 11:13:40 pm »
but when you look into the peers tab they are shown 100% which is incorrect.

I'll look into it, maybe a rounding error.

sledgehammer_999

  • qBittorrent maintainer
  • Administrator
  • Forum addict
  • *****
  • Posts: 2406
  • Karma: +150/-2
    • View Profile
Re: [unofficial]qBittorrent git master builds: 3.1.0alpha01092013
« Reply #107 on: September 10, 2013, 12:06:21 am »
but when you look into the peers tab they are shown 100% which is incorrect.

I'll look into it, maybe a rounding error.

It's a rounding error. QString::number(0.999*100.0,'f',1) gives 99.9 but QString::number(0.9999*100.0,'f',1) gives 100.0. I'll see how this can be corrected.

sledgehammer_999

  • qBittorrent maintainer
  • Administrator
  • Forum addict
  • *****
  • Posts: 2406
  • Karma: +150/-2
    • View Profile
Re: [unofficial]qBittorrent git master builds: 3.1.0alpha01092013
« Reply #108 on: September 11, 2013, 12:26:02 am »
but when you look into the peers tab they are shown 100% which is incorrect.

I'll look into it, maybe a rounding error.

It's a rounding error. QString::number(0.999*100.0,'f',1) gives 99.9 but QString::number(0.9999*100.0,'f',1) gives 100.0. I'll see how this can be corrected.

Should be fixed now in git master.

Nemo

  • qBittorrent Forum
  • Administrator
  • Forum addict
  • *****
  • Posts: 1477
  • Karma: +93/-0
    • View Profile
Re: [unofficial]qBittorrent git master builds: 3.1.0alpha01092013
« Reply #109 on: September 11, 2013, 03:29:33 pm »
Nice, thanks for the headsup sledge.
Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.




sledgehammer_999

  • qBittorrent maintainer
  • Administrator
  • Forum addict
  • *****
  • Posts: 2406
  • Karma: +150/-2
    • View Profile
Re: [unofficial]qBittorrent git master builds: 3.1.0alpha01092013
« Reply #110 on: September 19, 2013, 12:41:46 am »
Here is a new alpha build with libtorrent RC_0_16(r8971) -> http://builds.shiki.hu/qbittorrent_3.1.0alpha_19092013_setup.exe

Hot new feature: Now the "Add new torrent" dialog is always brought to the front.
Also, you now can enter just infohash in the "add torrent from link" window.
Scheduler logic is more robust
Some possible rounding errors were fixed all over the place.
And wrong ETA when users had downloaded one file, unchecked and checked on other.


Nemo

  • qBittorrent Forum
  • Administrator
  • Forum addict
  • *****
  • Posts: 1477
  • Karma: +93/-0
    • View Profile
Re: [unofficial]qBittorrent git master builds: 3.1.0alpha19092013
« Reply #111 on: September 19, 2013, 01:09:19 am »
Thanks sledge, nice improvments again.
Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.




tekko

  • Guest
Re: [unofficial]qBittorrent git master builds: 3.1.0alpha01092013
« Reply #112 on: September 19, 2013, 07:19:36 am »
Here is a new alpha build with libtorrent RC_0_16(r8971) -> http://builds.shiki.hu/qbittorrent_3.1.0alpha_19092013_setup.exe

Now the "Add new torrent" dialog is always brought to the front.

Would you please make this into an option? The dialog is in the way when opening multiple torrents at once within the browser. Thanks.

Nemo

  • qBittorrent Forum
  • Administrator
  • Forum addict
  • *****
  • Posts: 1477
  • Karma: +93/-0
    • View Profile
Re: [unofficial]qBittorrent git master builds: 3.1.0alpha19092013
« Reply #113 on: September 19, 2013, 07:16:08 pm »
Working great so far, very stable and good speeds up and down. I will let it run for 24 hours now to see how it goes with mem usage and other things.
Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.




sledgehammer_999

  • qBittorrent maintainer
  • Administrator
  • Forum addict
  • *****
  • Posts: 2406
  • Karma: +150/-2
    • View Profile
Re: [unofficial]qBittorrent git master builds: 3.1.0alpha01092013
« Reply #114 on: September 19, 2013, 10:53:23 pm »
Here is a new alpha build with libtorrent RC_0_16(r8971) -> http://builds.shiki.hu/qbittorrent_3.1.0alpha_19092013_setup.exe

Now the "Add new torrent" dialog is always brought to the front.

Would you please make this into an option? The dialog is in the way when opening multiple torrents at once within the browser. Thanks.

Although I am generally skeptic when adding new options because I don't want bloat, I can see why this can be obnoxious. I'll implemented an option.

bobinmk

  • Member
  • **
  • Posts: 55
  • Karma: +0/-0
    • View Profile
Re: [unofficial]qBittorrent git master builds: 3.1.0alpha19092013
« Reply #115 on: September 20, 2013, 02:51:05 am »
@ did someone checked with libtorrent 0.16.11. Finds problems with windows 8 (32 bit) loading probs.

tekko

  • Guest
Re: [unofficial]qBittorrent git master builds: 3.1.0alpha01092013
« Reply #116 on: September 20, 2013, 06:02:35 am »
...
Although I am generally skeptic when adding new options because I don't want bloat, I can see why this can be obnoxious. I'll implemented an option.

Thank you very much and 3.1.0alpha19092013 seems to be stable so far.

alfrix

  • Member
  • **
  • Posts: 21
  • Karma: +0/-0
    • View Profile
Re: [unofficial]qBittorrent git master builds: 3.1.0alpha19092013
« Reply #117 on: September 22, 2013, 08:51:06 pm »
testing lastest alpha, bring to front works, new metadata retrieval seems to work too, but if the queue is enabled metadata retrieval is queued too, making it never finish until it reaches the download position on the queue, also i had to re-assign folders and labels of ~200 torrents lots of times by now, at first i thinked it was something related with the power management of hdds (i have multiple hdds) so when qBt tries to access the disk when its sleeping, it takes too long and times-out so i disabled disk-sleep but a lot of times just fails after a normal shutdown, i know i'm not the only one because i checked the open issues and there are a lot of duplicates of the same behavior being reported over and over, a bug like this alienates people from the client like everytime i install an update the file associations break, and the option to re-associate doesn't work if the client wasn't opened as admin, but the most important bug was never fixed and years passed since it was first discovered, something needs to be done over the way the torrent folder/labels/status is saved, this hurts the torrent community since when it happens people just delete the torrent since they already have the file

sledgehammer_999

  • qBittorrent maintainer
  • Administrator
  • Forum addict
  • *****
  • Posts: 2406
  • Karma: +150/-2
    • View Profile
Re: [unofficial]qBittorrent git master builds: 3.1.0alpha19092013
« Reply #118 on: September 24, 2013, 12:43:30 am »
Quote
testing lastest alpha, bring to front works, new metadata retrieval seems to work too, but if the queue is enabled metadata retrieval is queued too, making it never finish until it reaches the download position on the queue, also i had to re-assign folders and labels of ~200 torrents lots of times by now, at first i thinked it was something related with the power management of hdds (i have multiple hdds) so when qBt tries to access the disk when its sleeping, it takes too long and times-out so i disabled disk-sleep but a lot of times just fails after a normal shutdown,

Yes, I know. Take a look at this: https://github.com/qbittorrent/qBittorrent/issues/894
I have implemented most of those changes discussed on the bug, locally. However, the code seems to busy-loop somewhere in a non-obvious and I have to debug to sort this out. I was hoping to release 3.1.0 this weekend but it won't happen. This feature/improvement need to be implemented first. Otherwise, the feature will feel halfbaked. All other issues marked with the "3.1.0" milestone will be transfered to a "3.1.1" milestone instead.

Quote
i know i'm not the only one because i checked the open issues and there are a lot of duplicates of the same behavior being reported over and over, a bug like this alienates people from the client like everytime i install an update the file associations break, and the option to re-associate doesn't work if the client wasn't opened as admin, but the most important bug was never fixed and years passed since it was first discovered, something needs to be done over the way the torrent folder/labels/status is saved, this hurts the torrent community since when it happens people just delete the torrent since they already have the file

Since I don't know the real cause of the problem, I just have to re-write how each torrent's status gets saved. Something like this: https://github.com/qbittorrent/qBittorrent/issues/583
However, this requires A LOT of careful work. TorrentPersistentData is used all over the place. It's not an easy task to undertake. So no ETA unfortunately.

Nemo

  • qBittorrent Forum
  • Administrator
  • Forum addict
  • *****
  • Posts: 1477
  • Karma: +93/-0
    • View Profile
Re: [unofficial]qBittorrent git master builds: 3.1.0alpha19092013
« Reply #119 on: September 24, 2013, 03:15:46 pm »
Sledge, did something change with connections/connecting to the peers with lib 16.11? I was downloading something and suddenly the speed went way down and stayed there, all active uploading peers were uploading with only 4-6KB/s (some even lower) and stayed that way. After restarting qBittorrent everything was normal again. For me it seemed like a huge lag came out of nowhere, but I never experienced this in earlier builds. A few notes: My current OS is W7 SP1 64Bit. qBittorrent was running for 1,5 days straight. This never happened with 3.0.11 so I reverted back just in case. I was using this alpha since its released without this weird behaviour, saw it in the morning. I forgot to make a screenshot but if I catch it again I take one quick.
« Last Edit: September 24, 2013, 03:21:13 pm by Nemo »
Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.