Author Topic: [COMPILE PROBLEM] qBt 3.0.8 (may be others) (OSX 10.8.2)  (Read 1393 times)

alter

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
[COMPILE PROBLEM] qBt 3.0.8 (may be others) (OSX 10.8.2)
« on: February 01, 2013, 09:52:50 PM »
I was trying to compile QBittorrent 3.0.8 from the source tarball (stable),  I have installed boost libraries and libtorrent , both from source code (no mac ports).
I notice that the configure script look for libboost libraries with the .so extension or without it to check if boost is present in the system, but shared libraries in MacOS now have the .dylib extension, so i change it manually on the ./configure script  (line 459 or line 469 if you had boost compiled with layer=system option). now it compiles fine.

Dont know if this is a bug or something, maybe I'm missing some parameter to pass to the configure script.

questions :

its a bug?
how are macos packages generated?

greetings

(pd: not native english speaker)
« Last Edit: February 01, 2013, 09:57:16 PM by alter »

Peter

  • Administrator
  • Forum addict
  • *****
  • Posts: 1614
  • Karma: +37/-2
    • View Profile
Re: [COMPILE PROBLEM] qBt 3.0.8 (may be others) (OSX 10.8.2)
« Reply #1 on: June 06, 2013, 11:17:41 AM »
I know the thread is old, but if the problem is still there, make a bugreport on github.
(And post the link here.)
- qBittorrent team - server and forum administrator.
- Hungarian translation reviewer/moderator (+ translator).

Join the official qBittorrent Discord!
https://discord.gg/ma66Vv4