Author Topic: Error: need libtorrent-rasterbar >= 0.15.0!  (Read 1227 times)

aealvarez3

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Error: need libtorrent-rasterbar >= 0.15.0!
« on: July 14, 2014, 09:16:22 pm »
Quote
[root@TorrentSFDC qbittorrent-3.1.9.2]# ./configure
Configuring qbittorrent ...
Verifying Qt 4 build environment ... ok
Checking for Qt >= 4.6 ... yes
Checking for QtDBus >= 4.5 ... yes
Checking for pkg-config executable ... yes
Checking for libtorrent-rasterbar >= 0.15.0 ... no

Error: need libtorrent-rasterbar >= 0.15.0!

I have just finished installing libtorrent-rasterbar 0.15.0. I am still getting this output when i try and configure qbittorrent. I am not sure why it does not recognize libtorrent. I have the output for my libtorrent if needed. Before i installed libtorrent i got a different output when trying to configure qbittorrent. Something along the lines of the enviroment wasn't setup for qbittorrent. Please someone help it will be greatly appreciated.

loki

  • Forum addict
  • ****
  • Posts: 567
  • Karma: +16/-1
    • View Profile
Re: Error: need libtorrent-rasterbar >= 0.15.0!
« Reply #1 on: July 17, 2014, 01:49:04 am »
Did you have to use libtorrent version 0.15.0? Depending on what linux you use, there's almost certainly a newer (supported) version available. For compiling you might need at least the 0.16.0 packages... I'm not sure why it still says 0.15.0.

sledgehammer_999

  • qBittorrent maintainer
  • Administrator
  • Forum addict
  • *****
  • Posts: 2406
  • Karma: +150/-2
    • View Profile
Re: Error: need libtorrent-rasterbar >= 0.15.0!
« Reply #2 on: July 17, 2014, 08:18:57 am »
Run in a terminal window:

Code: [Select]
pkg-config --list-all | grep libtorrent
What is the output?