Author Topic: Qbittorrent won't work  (Read 2960 times)

StillSurfing

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Qbittorrent won't work
« on: December 05, 2014, 01:06:13 pm »
Hello fellow sharers. Just after I installed Yosemite (previously Mavericks) Qbittorrent stopped working, firstly it displayed no search results found no matter what I searched for, tried deleting Qbittorrent but now when I start to download it Im informed that its not compatible with my OS. Ive tried a couple of suggestions found on the web but to no avail. I use my Mac lots but don't usually delve beyond normal settings. Hope you can help.

weezly

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Qbittorrent won't work
« Reply #1 on: December 26, 2014, 03:24:43 am »
Its kinda weird, because X 10.10.x is available for quite  some time but there is none of any stable releases of qBittorrent.
I even did test trying run it in vm and it crashes both in 10.8 and 10.9.. kinda weird.
Anyway, as long as Transmission works well it does not change much for me. Still -- just weird.
After Mavericks was released i think in relatively short time qBittorrent arrived as well.

I suspect  conspiracy.
:)


sledgehammer_999

  • qBittorrent maintainer
  • Administrator
  • Forum addict
  • *****
  • Posts: 2406
  • Karma: +150/-2
    • View Profile
Re: Qbittorrent won't work
« Reply #2 on: December 26, 2014, 08:32:54 pm »
You can choose to download v3.1.11.1
It should work now.
He don't have a stable MAC packager and I don't own any MAC hardware either.

weezly

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Qbittorrent won't work
« Reply #3 on: December 28, 2014, 12:26:43 am »
You can choose to download v3.1.11.1
It should work now.
He don't have a stable MAC packager and I don't own any MAC hardware either.

I check from time to time to see if new version is available, and i did check last one too -- still, crashes at start..
:)

Perrytone

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Qbittorrent won't work
« Reply #4 on: December 29, 2014, 04:12:01 am »
3.1.11.1 works fine.  But, if I installed macports, it crashes and produces this error:

Process:               qbittorrent [5686]
Path:                  /Applications/qBittorrent.app/Contents/MacOS/qbittorrent
Identifier:            org.qbittorrent
Version:               3.1.11 (???)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           qbittorrent [5686]
User ID:               501

Date/Time:             2014-12-28 21:22:07.983 -0400
OS Version:            Mac OS X 10.10.1 (14B25)
Report Version:        11
Anonymous UUID:        94290932-2E11-0F93-3047-074C3931C463


Time Awake Since Boot: 15000 seconds

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes:       0x0000000000000001, 0x0000000000000000

Application Specific Information:
/Applications/qBittorrent.app/Contents/MacOS/../Frameworks/libtorrent-rasterbar.7.dylib

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libtorrent-rasterbar.7.dylib     0x000000010ef2f277 std::__1::__tree<std::__1::__value_type<boost::asio::ip::address, libtorrent::udp_tracker_connection::connection_cache_entry>, std::__1::__map_value_compare<boost::asio::ip::address, std::__1::__value_type<boost::asio::ip::address, libtorrent::udp_tracker_connection::connection_cache_entry>, std::__1::less<boost::asio::ip::address>, true>, std::__1::allocator<std::__1::__value_type<boost::asio::ip::address, libtorrent::udp_tracker_connection::connection_cache_entry> > >::destroy(std::__1::__tree_node<std::__1::__value_type<boost::asio::ip::address, libtorrent::udp_tracker_connection::connection_cache_entry>, void*>*) + 373
1   dyld                             0x00007fff6c08cceb ImageLoaderMachO::doModInitFunctions(ImageLoader::LinkContext const&) + 265
2   dyld                             0x00007fff6c08ce78 ImageLoaderMachO::doInitialization(ImageLoader::LinkContext const&) + 40
3   dyld                             0x00007fff6c089871 ImageLoader::recursiveInitialization(ImageLoader::LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 305
4   dyld                             0x00007fff6c089806 ImageLoader::recursiveInitialization(ImageLoader::LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 198
5   dyld                             0x00007fff6c0896f8 ImageLoader::processInitializers(ImageLoader::LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 138
6   dyld                             0x00007fff6c089969 ImageLoader::runInitializers(ImageLoader::LinkContext const&, ImageLoader::InitializerTimingList&) + 75
7   dyld                             0x00007fff6c07c245 dyld::initializeMainExecutable() + 187
8   dyld                             0x00007fff6c07fbe1 dyld::_main(macho_header const*, unsigned long, int, char const**, char const**, char const**, unsigned long*) + 2716
9   dyld                             0x00007fff6c07b276 dyldbootstrap::start(macho_header const*, int, char const**, long, macho_header const*, unsigned long*) + 512
10  dyld                             0x00007fff6c07b036 _dyld_start + 54

Thread 0 crashed with X86 Thread State (64-bit):
  rax: 0x000000010eff26f0  rbx: 0x000000010ef2f210  rcx: 0x00007fff5159bb58  rdx: 0x00007fff5159baa0
  rdi: 0x0000000000000002  rsi: 0x00007fff5159ba88  rbp: 0x00007fff515991d0  rsp: 0x00007fff515991c0
   r8: 0x00007fff6c0b2660   r9: 0x00007fff77dcc300  r10: 0x0000000000001c20  r11: 0x00007fff8d3a6f74
  r12: 0x000000010efe60b0  r13: 0x00007fff6c0b2598  r14: 0x00007fff6c0b9a08  r15: 0x00000000000000cc
  rip: 0x000000010ef2f277  rfl: 0x0000000000010202  cr2: 0x000000010ef2f140
 
Logical CPU:     0
Error Code:      0x00000000
Trap Number:     6
« Last Edit: December 29, 2014, 09:35:09 am by Perrytone »

9pigs

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
Re: Qbittorrent won't work
« Reply #5 on: January 04, 2015, 01:21:20 am »
I went through all that with the current "stable" releases also -- same crash report/ bug (reported).  Note that the last time I looked, the reports had the same app failure -- and Intel Core 2 Duo processors. Note your crash report was cut short before the hardware part.   :'(

 qBittorrent 3.1.3 http://sourceforge.net/projects/qbittorrent/files/qbittorrent-mac/ works on my Yosemite Core 2 Duo machine.  ;)

guygizmo

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Qbittorrent won't work
« Reply #6 on: January 09, 2015, 03:41:57 am »
I'm getting the exact same crash as Perrytone. I don't have macports installed but I do have homebrew installed. Any idea what's going wrong?

Have to roll back to v3.1.9.1 now. :-(