Author Topic: "Engine plugin could not be installed"  (Read 1321 times)

ancucchi

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
"Engine plugin could not be installed"
« on: July 17, 2015, 09:13:06 pm »
    From today when I search something, qbittorrent do not find anything.
    When I push on the button Search engines..., the program open the window Search plugins, where usually I saw the plugin installed, empty. But If i push the button "Check for updates" a lot of new windows advice me that xxxxxxx search engine plugin could not be updated, keeping old version.
    If I try to install a brand new search engine, a new window advice me that search engine plugin could not be installed.
    If I open a window of my file manager and I go to " /home/tony/.local/share/data/qBittorrent/nova/engines", I can find a new file with the same name of search engine plugin that I try to install, but with a different extension: -pyc instead of .py .
    I tried to reinstall qBittorrent with " apt-get --reinstall install qbittorrent" but nothing change.
    I use LinuxMint 17.2 Rafaela 64bit on a Intel Core 2 Quad CPU Q8400 with 5 Gigabyte RAM.
    I use version 3.2.0 of qBittorrent with the follow libraries:
    • Qt: 4.8.6
    • Libtorrent: 0.16.13.0
    • Boost: 1.54

ciaobaby

  • Forum addict
  • ****
  • Posts: 2771
  • Karma: +98/-25
  • No quarter asked... No quarter given.
    • View Profile
    • WMTeu
Re: "Engine plugin could not be installed"
« Reply #1 on: July 18, 2015, 10:28:13 pm »
https://qbforums.shiki.hu/index.php/topic,3587.0.html

What version of python is on your machine?
Smarter than the av-er-age bear, Boo Boo.

http://qbforums.shiki.hu/index.php/topic,3084.0.html

ancucchi

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: "Engine plugin could not be installed"
« Reply #2 on: July 19, 2015, 09:24:16 am »
https://qbforums.shiki.hu/index.php/topic,3587.0.html

What version of python is on your machine?
Thanks Ciaobaby.
You give me the right idea.
Ten days ago I had a very bad idea: install an old version of python (2.5.4) to try a tool.
Yesterday, when I read your post, I remembered my stupid action.
I tried to uninstall the old python, but when I tried with apt-get, system suggest me that for dependences it will uninstall a lot of thing native of my linux distro...
I read the how-to of the package that i used for the install, but it do not provide anything to remove.

After 30 minute of attempts and Google Search, I found this solution that create a symlink to use right version.
update-alternatives --install /usr/local/bin/python python /usr/bin/python2.7 1
The first time I use it, a message advice me that it can not create the simlink, so I renamed the original wrong python in python_wrong and tried again.
This time all gone good and my qbittorrent come to full and right work.

In this occasion I discover that python is the spine of my distro linux and play with it installing many different version may be very dangerous...