Author Topic: [official]qBittorrent 3.3.16 installer - Built with MSVC 2017  (Read 28147 times)

yaitanes

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: [official]qBittorrent 3.3.16 installer - Built with MSVC 2017
« Reply #165 on: September 08, 2017, 05:41:04 am »
in a non-related topic, can i ask if there is a special reason behind the yyyyddmm format in "3.4.0beta2_20170709_cbfbae14090" cuz this is really confusing for me

sledgehammer_999

  • qBittorrent maintainer
  • Administrator
  • Forum addict
  • *****
  • Posts: 2361
  • Karma: +145/-1
    • View Profile
Re: [official]qBittorrent 3.3.16 installer - Built with MSVC 2017
« Reply #166 on: September 08, 2017, 08:48:07 am »
in a non-related topic, can i ask if there is a special reason behind the yyyyddmm format in "3.4.0beta2_20170709_cbfbae14090" cuz this is really confusing for me

Just a stupid mistake. I was doing 6 packages and was tired. I actually wanted yyyymmdd format.

zavalita

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: [official]qBittorrent 3.3.16 installer - Built with MSVC 2017
« Reply #167 on: September 09, 2017, 09:42:04 pm »
This second Beta finally works perfectly for me, regarding seeding at least - finally I'm using all of my 250 mbs UL bandwidth, with no fluctuations (as the stable and first beta versions were having).




siradude

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: [official]qBittorrent 3.3.16 installer - Built with MSVC 2017
« Reply #168 on: September 17, 2017, 11:47:57 pm »
I found a BUG? or a problem in the 3.3.16 installer?
(maybe it has been found before?, cant find answer)

I have the 3.3.15 x64 installer and it works fine (installs and uninstalls and re-installs)
But with the new installer (3.3.16 and beta 3.4) I keep getting a NEED ADMINISTRATOR RIGHTS to install screen to continue installation at the very start.
Were I can choose my current USER or the ADMINISTRATOR user...

YES! I tried run as administrator but no luck, get same screen! Tried uninstalling previous version, same result at new installation. My UAC is set to the lowest setting.

Well ... My Pc (windows 10 PRO) is configured to use a MICROSOFT account to login... with administrative rights. and of course the ADMINISTRATOR account is disabled.
I have no other LOCAL USER configured nor do I want to have..
Maybe the problem has to do with using a Microsoft account to login?

Thanks in advanced for any HELP!

The only way around this was to install  3.3.15 and over write with files from uncompressed installation, (seems to work)
« Last Edit: September 17, 2017, 11:50:35 pm by siradude »

sledgehammer_999

  • qBittorrent maintainer
  • Administrator
  • Forum addict
  • *****
  • Posts: 2361
  • Karma: +145/-1
    • View Profile
Re: [official]qBittorrent 3.3.16 installer - Built with MSVC 2017
« Reply #169 on: September 17, 2017, 11:53:31 pm »
All installer required admin rights.
And I haven't changed the installer scripts between v3.3.15 and v3.3.16, so it is weird why one works and the other doesn't.

What of kind of screen do you get when you choose to run as current USER or the ADMINISTRATOR user? (screenshot if possible)

siradude

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: [official]qBittorrent 3.3.16 installer - Built with MSVC 2017
« Reply #170 on: September 18, 2017, 12:01:39 am »
If I select the Current user or type the user credentials (cant try administrator unless I activate the account) I get this screen (in attachement)

Maybe it has to do with it finding a previous version installed and needing rights to over write? (even though I did uninstall the previous)

As stated before the 3.3.15. works perfectly

siradude

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: [official]qBittorrent 3.3.16 installer - Built with MSVC 2017
« Reply #171 on: September 18, 2017, 12:06:29 am »
Just found that it only seems to work... at least I don't get admin rights screen is if I run it in compatibility mode for WINDOWS XP SP3
no other compatibility mode works... not Win 7, Win 8 or Vista. So it might be an UAC problem?


Verified, installation under compatibility mode for WIN XP SP3 worked like a charm.
Detected previos version and installed over it.
« Last Edit: September 18, 2017, 12:08:21 am by siradude »

sledgehammer_999

  • qBittorrent maintainer
  • Administrator
  • Forum addict
  • *****
  • Posts: 2361
  • Karma: +145/-1
    • View Profile
Re: [official]qBittorrent 3.3.16 installer - Built with MSVC 2017
« Reply #172 on: September 18, 2017, 12:15:33 am »
Does your current user have admin rights?

siradude

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: [official]qBittorrent 3.3.16 installer - Built with MSVC 2017
« Reply #173 on: September 18, 2017, 12:17:22 am »
NEVER MIND!

Just reset my UAC to normal level and rebooted and installation worked fine.
Went back to UAC and lowered to my usual lowest level and rebooted and you install kept working.

Might have been something to do with my machine being accessed constantly remotely RDC or needing a reboot (may be updates?)

but its all working fine now.

NOTE: Yes my current user is admin.... odd thing

THANKS FOR YOUR HELP!  :)
« Last Edit: September 18, 2017, 12:19:45 am by siradude »

sledgehammer_999

  • qBittorrent maintainer
  • Administrator
  • Forum addict
  • *****
  • Posts: 2361
  • Karma: +145/-1
    • View Profile
Re: [official]qBittorrent 3.3.16 installer - Built with MSVC 2017
« Reply #174 on: September 18, 2017, 12:30:03 am »
NEVER MIND!

Just reset my UAC to normal level and rebooted and installation worked fine.
Went back to UAC and lowered to my usual lowest level and rebooted and you install kept working.

FYI, qbittorrent itself doesn't need admin rights. Only the installer/uninstaller.