Author Topic: Why does the Network Interface setting not work on OS X as it does on Windows?  (Read 1536 times)

throwawayssminow

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
I use a VPN.

On my Windows PC, if I set the Network Interface option to my VPN and then I'm not connected to the VPN, qBittorrent will not connect/download/upload, as it shouldn't.

However, if I have the same setting on my Macbook, and I run qBittorrent without being connected to my VPN, then torrents are still connected and downloaded/uploaded through my regular internet.

Is that on purpose? The settings are the same between my Windows desktop and Macbook but only the Windows version of qBittorrent is using ONLY the specified network interface. If I have the Network Interface set to my VPN on my Macbook, why is it running through my regular internet too?
« Last Edit: June 17, 2016, 02:19:16 AM by throwawayssminow »

KitKat

  • Veteran
  • ***
  • Posts: 340
  • Karma: +26/-0
  • Here i stand with my bayonet...
    • View Profile
Did you restart the qbt client after changing the network bindings on your Macbook?
Is the VPN properly initialised on your macbook?
What version of qbittorent are you running? Both same 3.3.4 or higher or is the macbook on an older one?

Is that on purpose?

Definitely not on purpose, its a bug not a feature..
The following BBC is not allowed within your signature: html, img, php.

throwawayssminow

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Did you restart the qbt client after changing the network bindings on your Macbook?
Is the VPN properly initialised on your macbook?
What version of qbittorent are you running? Both same 3.3.4 or higher or is the macbook on an older one?

Is that on purpose?

Definitely not on purpose, its a bug not a feature..

Thank you for taking the time to reply.

Yes, I tried restarting qBittorrent.
VPN is properly initialized and I've verified it's properly connected.
Windows version is 3.2.4 and OS X version is 3.2.5

After more research it seems this problem has been around for a while. This is a quote from a post someone made in March, 2015:
"Bind to interface is not secure if VPN interface is removed during torrenting (i.e. by closing PIA client). Testing in OS X peer traffic continues on en1 when it should stop altogether."

Again, that's only for OS X; on Windows, if the VPN is removed during torrenting, the connection will halt.
« Last Edit: June 18, 2016, 12:33:31 AM by throwawayssminow »

KitKat

  • Veteran
  • ***
  • Posts: 340
  • Karma: +26/-0
  • Here i stand with my bayonet...
    • View Profile
Do you really mean 3.2.4/5?
Not 3.3.4/5?

Your client is quite out of date, can you try updating and seeing if the issue persists, i personally never used the 3.2 series of qbittorent :(
The following BBC is not allowed within your signature: html, img, php.