Author Topic: Limit on uploads not working  (Read 2231 times)

Ageless

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Limit on uploads not working
« on: April 20, 2016, 12:17:40 am »

I've got a limit on the uploads set to 1,200 kbps, or 1.1MiB/sec, but qbittorrent 3.3.4 ignores it.

My internet connection is a 200Mbit/20Mbit one, but it's shared between 3 PCs, a NAS and several handheld devices, so I set all my torrent limits to 1,200 kbps so that none of these can saturate the upload on their own. Of course we do expect the limit to be upheld then.

tekko

  • Guest
Re: Limit on uploads not working
« Reply #1 on: April 20, 2016, 02:59:12 am »
options > speed

check "Apply rate limit to transport overhead", "Apply rate limit to peers on LAN", "Apply rate limit to µTP protocol"

KitKat

  • Veteran
  • ***
  • Posts: 340
  • Karma: +26/-0
  • Here i stand with my bayonet...
    • View Profile
Re: Limit on uploads not working
« Reply #2 on: April 20, 2016, 05:24:35 am »

I've got a limit on the uploads set to 1,200 kbps, or 1.1MiB/sec, but qbittorrent 3.3.4 ignores it.

My internet connection is a 200Mbit/20Mbit one, but it's shared between 3 PCs, a NAS and several handheld devices, so I set all my torrent limits to 1,200 kbps so that none of these can saturate the upload on their own. Of course we do expect the limit to be upheld then.
Silly question, but are you using the actually using the rate you set? (global/alternative)
qbittorent allows you to set 2 different rates and you swap between them by clicking the speedometer icon next to the upload/download amount.
3.3.4 respects the rates i set, if you have told it to use the correct rate (global/alternative) and it still isnt respecting it, run qbittorent as admin and set the rates again.
Its possible your setup prevents qbittorent from modifying its config file, may want to take ownership of %appdata%\qbittorrent\qbittorrent.ini or give the "user" group permission to modify it.
The following BBC is not allowed within your signature: html, img, php.

Ageless

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Limit on uploads not working
« Reply #3 on: April 20, 2016, 09:51:39 am »
options > speed

check "Apply rate limit to transport overhead", "Apply rate limit to peers on LAN"
These two won't do it. Checked those, clicked Apply, clicked OK, waited 10 minutes, and still got 2.0MiB/s.
(I don't have any peers on the LAN)

Quote
"Apply rate limit to µTP protocol"
With this one checked, it seems to go over slightly (max 1.3 MiB/s) for seconds. Trouble is, with this one checked, my download speeds drop enormously. For exactly the same downloads, with it checked, downloads don't go much over 100KiB/s, while with it unchecked, I reach multiple MiB/s.

The rate limit I set should be global, not just for the uTP protocol. And else split the option, so the user is able to set this preference for uploads and downloads, or only either. (Unless that's already possible via manual modifying of a config file?)
« Last Edit: April 20, 2016, 09:54:13 am by Ageless »

Ageless

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Limit on uploads not working
« Reply #4 on: April 20, 2016, 09:52:50 am »
Silly question, but are you using the actually using the rate you set? (global/alternative)
I've got both set to the same limits, 1,200KiB/sec up and 12,500KiB/sec down.
Because of loads of stalled downloads, I run qbittorrent default with elevation as administrator.

Quote
Its possible your setup prevents qbittorent from modifying its config file, may want to take ownership of %appdata%\qbittorrent\qbittorrent.ini or give the "user" group permission to modify it.
I don't run with a user on my system, only with one administrator account and the Windows admin account for elevations.