Author Topic: PPA LinuxMint 17.3 does not update qbittorrent  (Read 221 times)

Robertomcat

  • Member
  • **
  • Posts: 20
  • Karma: +0/-0
    • View Profile
PPA LinuxMint 17.3 does not update qbittorrent
« on: March 10, 2017, 08:41:00 PM »
Hi, good evening (from Valencia, Spain).

It turns out that for three days now it has been released to update 3.3.11, but from the repositories of Linuxmint the client has not yet been updated. I think maybe it's a bit early for this latest version in these repositories, but as I'm a little dubious I leave here this comment to know if anyone knows anything about this topic.

Please, someone who has not yet updated the client from the PPAs of some Linux system?

Thank you very much and greetings!
« Last Edit: March 17, 2017, 01:06:04 PM by Robertomcat »

Peter

  • Administrator
  • Forum addict
  • *****
  • Posts: 1350
  • Karma: +30/-1
    • View Profile
Re: PPA LinuxMint 17.2 does not update qbittorrent
« Reply #1 on: March 14, 2017, 04:12:55 PM »
Regular people - such as the qBittorrent team - cannot upload new versions to the repository of Linux Mint, Debian or Ubuntu for example.
Simply, add the Ubuntu PPA (for Linux Mint), and it will update and work like a charm.

The official site says: Linux Mint 17.2 features Cinnamon 2.6, MDM 2.0, a Linux kernel 3.16 and an Ubuntu 14.04 package base.

You can add the repo from here: https://launchpad.net/~qbittorrent-team/+archive/ubuntu/qbittorrent-stable

Just use the commands:
Code: [Select]
sudo add-apt-repository ppa:qbittorrent-team/qbittorrent-stable
sudo apt-get update
- qBittorrent team - server and forum administrator.
- Hungarian translation reviewer/moderator (+ translator).

Robertomcat

  • Member
  • **
  • Posts: 20
  • Karma: +0/-0
    • View Profile
Re: PPA LinuxMint 17.2 does not update qbittorrent
« Reply #2 on: March 14, 2017, 04:26:19 PM »
Regular people - such as the qBittorrent team - cannot upload new versions to the repository of Linux Mint, Debian or Ubuntu for example.
Simply, add the Ubuntu PPA (for Linux Mint), and it will update and work like a charm.

The official site says: Linux Mint 17.2 features Cinnamon 2.6, MDM 2.0, a Linux kernel 3.16 and an Ubuntu 14.04 package base.

You can add the repo from here: https://launchpad.net/~qbittorrent-team/+archive/ubuntu/qbittorrent-stable

Just use the commands:
Code: [Select]
sudo add-apt-repository ppa:qbittorrent-team/qbittorrent-stable
sudo apt-get update

Thanks for answering.

It turns out that this repository has long been installed, and qbittorrent is in version 3.3.10, but it is not updated to the newer version. What could be wrong with this?



Peter

  • Administrator
  • Forum addict
  • *****
  • Posts: 1350
  • Karma: +30/-1
    • View Profile
Re: PPA LinuxMint 17.2 does not update qbittorrent
« Reply #3 on: March 14, 2017, 04:44:08 PM »
In that Software Manager that you just used.. try looking for "Update repository" or "Update list".
It's simply that your machine has not checked if there is a new version.

Once it checks, and sees it, the update will be offered to you.
Or, you can manually update too, using that software.
- qBittorrent team - server and forum administrator.
- Hungarian translation reviewer/moderator (+ translator).

Robertomcat

  • Member
  • **
  • Posts: 20
  • Karma: +0/-0
    • View Profile
Re: PPA LinuxMint 17.2 does not update qbittorrent
« Reply #4 on: March 14, 2017, 05:11:02 PM »
In that Software Manager that you just used.. try looking for "Update repository" or "Update list".
It's simply that your machine has not checked if there is a new version.

Once it checks, and sees it, the update will be offered to you.
Or, you can manually update too, using that software.
I've updated the list as I've been told, but Mint does not detect the new qbittorrent package. I opened it in the repository and it came out this:


As for the manual update, I can not find the .deb package

Peter

  • Administrator
  • Forum addict
  • *****
  • Posts: 1350
  • Karma: +30/-1
    • View Profile
Re: PPA LinuxMint 17.2 does not update qbittorrent
« Reply #5 on: March 15, 2017, 09:37:01 AM »
That is just very weird.
Try simply a Terminal. (Don't be afraid, doesn't bite.)


Quote
sudo apt-get update
sudo apt-get dist-upgrade

It should upgrade.
(Mint's Update Manager is a bit crazy, like it holds off kernel updates and whatnot like they are the work of the devil. :D)
« Last Edit: March 15, 2017, 09:48:54 AM by Peter »
- qBittorrent team - server and forum administrator.
- Hungarian translation reviewer/moderator (+ translator).

Robertomcat

  • Member
  • **
  • Posts: 20
  • Karma: +0/-0
    • View Profile
Re: PPA LinuxMint 17.2 does not update qbittorrent
« Reply #6 on: March 15, 2017, 11:19:55 AM »
That is just very weird.
Try simply a Terminal. (Don't be afraid, doesn't bite.)


Quote
sudo apt-get update
sudo apt-get dist-upgrade

It should upgrade.
(Mint's Update Manager is a bit crazy, like it holds off kernel updates and whatnot like they are the work of the devil. :D)
Hello good day.

The truth is that it does not work with those commands either. I have tried to disable PPAs and update the cache and re-enable them, but it does not work either. I have changed the suppositories to some of England, and I have also updated the cache, and it does not work either.

The truth is that I do not know what can happen, because the last update 3.3.10 was updated through the PPA. :(

Peter

  • Administrator
  • Forum addict
  • *****
  • Posts: 1350
  • Karma: +30/-1
    • View Profile
Re: PPA LinuxMint 17.2 does not update qbittorrent
« Reply #7 on: March 15, 2017, 02:12:49 PM »
Yeah, and the PPA has the new version.
Hmm.

If you go into /etc/apt/sources.list.d/ folder, and open the qBittorrent PPA .list file, what's the content of it?
A file browser should be able to open this file, you don't need root or anything (only to edit).
- qBittorrent team - server and forum administrator.
- Hungarian translation reviewer/moderator (+ translator).

Robertomcat

  • Member
  • **
  • Posts: 20
  • Karma: +0/-0
    • View Profile
Re: PPA LinuxMint 17.2 does not update qbittorrent
« Reply #8 on: March 15, 2017, 02:18:34 PM »
Yeah, and the PPA has the new version.
Hmm.

If you go into /etc/apt/sources.list.d/ folder, and open the qBittorrent PPA .list file, what's the content of it?
A file browser should be able to open this file, you don't need root or anything (only to edit).
This is what is inside.


Robertomcat

  • Member
  • **
  • Posts: 20
  • Karma: +0/-0
    • View Profile

Peter

  • Administrator
  • Forum addict
  • *****
  • Posts: 1350
  • Karma: +30/-1
    • View Profile
Re: PPA LinuxMint 17.3 does not update qbittorrent
« Reply #10 on: March 18, 2017, 11:41:39 PM »
Nice find!

This is crazy.
Why would the main PPA page show the latest 3.0.11 version YET, they failed?
Even the repo (via web browser) shows only the 3.0.10 version.
I made PPAs myself, yet I never had this happen - or I don't remember this happening.

I have a Xenial deploy only, which was a "lucky version" that got built.
That's why I didn't even think the build failed.

Even though the latest log contains error, according to the Github ticket the PPA will need a new libtorrent (>1.1.0) before proceeding.
When will that get uploaded... good question.
The best answer I can give is "as soon as possible."

I am sorry for the confusion / "mislead".
- qBittorrent team - server and forum administrator.
- Hungarian translation reviewer/moderator (+ translator).

Robertomcat

  • Member
  • **
  • Posts: 20
  • Karma: +0/-0
    • View Profile
Re: PPA LinuxMint 17.3 does not update qbittorrent
« Reply #11 on: March 18, 2017, 11:45:57 PM »
Nice find!

This is crazy.
Why would the main PPA page show the latest 3.0.11 version YET, they failed?
Even the repo (via web browser) shows only the 3.0.10 version.
I made PPAs myself, yet I never had this happen - or I don't remember this happening.

I have a Xenial deploy only, which was a "lucky version" that got built.
That's why I didn't even think the build failed.

Even though the latest log contains error, according to the Github ticket the PPA will need a new libtorrent (>1.1.0) before proceeding.
When will that get uploaded... good question.
The best answer I can give is "as soon as possible."

I am sorry for the confusion / "mislead".
There is no problem, on the contrary, thank you very much for investigating and helping me to leave doubts. When it's released, I'll come back to warn you (if I can remember) :)