Author Topic: 4.0 builds for OSX?  (Read 2644 times)

victorhooi

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
4.0 builds for OSX?
« on: November 22, 2017, 09:08:09 pm »
Hi,

I noticed 4.0 is out (and now 4.0.1). Congratulations!

However, there don't seem to be any OSX builds on the download page (https://www.qbittorrent.org/download.php).

The latest OSX builds are 3.3.16.

Are the OSX builds coming shortly?

Thanks,
Victor

bwright

  • Newbie
  • *
  • Posts: 8
  • Karma: +2/-0
    • View Profile
Re: 4.0 builds for OSX?
« Reply #1 on: November 23, 2017, 05:07:23 am »
Unless there is a mac maintainer now (there wasn't around 3.4.0 from what I've read), I don't think there's an official build yet.

I haven't tested this outside of my dev laptop, but I have compiled 4.0.1 for Mac OS X:

https://github.com/bwrightkc/qbt-mac/releases/tag/4.0.1


Updated: https://github.com/bwrightkc/qbt-mac/releases/tag/4.0.1-2

Again, I haven't fully tested this binary and it is completely unofficial, but you're free to try it if you'd like. It is unsigned as well.
« Last Edit: November 23, 2017, 04:11:15 pm by bwright »

koot

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: 4.0 builds for OSX?
« Reply #2 on: November 23, 2017, 09:54:58 am »
Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Reason:    DYLD, [0x1] Library missing

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: @loader_path/libboost_system-mt.dylib
  Referenced from: /Applications/qbittorrent.app/Contents/Frameworks/libboost_chrono-mt.dylib
  Reason: image not found


OS Version:            Mac OS X 10.13.2 (17C79a)

fix duplicating libboost_system.dylib with name libboost_system-mt.dylib
« Last Edit: November 23, 2017, 10:25:33 am by koot »

stoli412

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: 4.0 builds for OSX?
« Reply #3 on: November 23, 2017, 02:22:29 pm »
I got the same message. Easy fix if you have Homebrew (https://brew.sh) installed on your mac.

In Terminal:
Code: [Select]
brew install boost
qBittorrent opens correctly after that.

bwright

  • Newbie
  • *
  • Posts: 8
  • Karma: +2/-0
    • View Profile
Re: 4.0 builds for OSX?
« Reply #4 on: November 23, 2017, 04:11:43 pm »

londinense

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: 4.0 builds for OSX?
« Reply #5 on: November 29, 2017, 09:00:51 pm »
Thanks. It is working fine for me so far. Whereas the official version periodically freezes.

qbmacuser

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: 4.0 builds for OSX?
« Reply #6 on: December 02, 2017, 02:43:14 am »
Hello, I am using 10.10.5, I could build both 4.0.1 and 4.0.2 with both qt 5.7 and 5.5, but i can't open the built app (cocoa library requested).
I can't mount your dmg, could you please build one with the updated 4.0.2?
System: 4790K 4GHz 4-Cores Mac OS 10.10.5
Thanks!

victorhooi

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: 4.0 builds for OSX?
« Reply #7 on: December 08, 2017, 08:30:51 pm »
@bwright:

Any chance of 4.0.2 builds as well? =) :)

bwright

  • Newbie
  • *
  • Posts: 8
  • Karma: +2/-0
    • View Profile
Re: 4.0 builds for OSX?
« Reply #8 on: December 09, 2017, 01:42:48 am »

victorhooi

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: 4.0 builds for OSX?
« Reply #9 on: January 22, 2018, 09:57:14 pm »
Hi,

Are there any updated builds for OSX?

Or an easy way to compile from Trunk?

Cheers,
Victor