Author Topic: False I/O Errors  (Read 416 times)

2635599

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
False I/O Errors
« on: November 26, 2017, 03:33:51 pm »
can you fix qbt not to give a i/o error when it can't find files? i moved several files yesterday without removing them from qbt and got repeating i/o errors. i quickly realized what was going on but not before almost having a stroke thinking the drive was failing. when we move files and forget to remove them from qbt first all qbt should be telling us is it can't find the files, and only on the main interface NOT passing that information to windows notifications.

hotshot

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: False I/O Errors
« Reply #1 on: December 13, 2017, 03:58:25 pm »
The bug is actually much worse than that. If you have only downloaded a partial set of files from a folder, leech requests for non-downloaded files set this off.

You get a constant string of i/o error messages if the non-downloaded files happen to be popular.

And of course it pauses the entire torrent for no good reason.
« Last Edit: December 13, 2017, 04:04:10 pm by hotshot »

2635599

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Re: False I/O Errors
« Reply #2 on: December 13, 2017, 04:37:33 pm »
i haven't seen that behavior at all. when i find a torrent i want i always uncheck everything in it i do not want, and never get the i/o errors. but that's not the issue, the issue is the i/o error messages are erroneous cause there is no hardware failure. 

grr.la

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: False I/O Errors
« Reply #3 on: December 17, 2017, 09:13:04 pm »
I'm seeing the same errors with some files but i'm not sure it just a false message. I can't copy a complete files to another location. Version 4 is truly a disaster.

Peter

  • Administrator
  • Forum addict
  • *****
  • Posts: 1506
  • Karma: +36/-2
    • View Profile
Re: False I/O Errors
« Reply #4 on: December 20, 2017, 12:57:30 am »
@grr.la
Worked for me since 4.0. On Windows 8.1, Windows 10 and Server 2016. And on Ubuntu 16.04 and 17.10. And Fedora 27.
Where are you putting the download folder? Does your user have 100% write/read rights over the folder? You sure you have no IO problems? You sure your RAM is fine? Any antivirus product? Have you tried disabling it/them?
- qBittorrent team - server and forum administrator.
- Hungarian translation reviewer/moderator (+ translator).

Dirty Scrummer

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: False I/O Errors
« Reply #5 on: December 21, 2017, 07:36:45 am »
qBit 4.03  Windows 7 HP 64 bit

I/O errors over 200 lines.

Happened with ?3.3.16 several times but only 10 lines

the two weeks with 4.02, nothing

day 3 with 4.03 extreme amount of I/O errors