Author Topic: Connected to peers, but not downloading  (Read 6942 times)

gizmo_pook

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Connected to peers, but not downloading
« on: March 06, 2018, 08:28:48 PM »
Hi there,

qBittorrent says I'm connected to peers, but it's not downloading. Some are halfway downloaded, but then stop while still connected. Is there something I should check, or change in the settings?

Thanks

Switeck

  • Forum addict
  • ****
  • Posts: 1114
  • Karma: +75/-0
    • View Profile
Re: Connected to peers, but not downloading
« Reply #1 on: March 06, 2018, 11:20:36 PM »
Does the same behavior (connected to peers+seeds but no downloading) happen on known-to-work-well Linux distro torrents?
(You don't even need to complete one of those downloads, just test for a couple minutes.)

gizmo_pook

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Connected to peers, but not downloading
« Reply #2 on: March 07, 2018, 12:03:50 AM »
Excuse my ignorance, but what is a Linux distro torrent?

Thanks

Switeck

  • Forum addict
  • ****
  • Posts: 1114
  • Karma: +75/-0
    • View Profile
Re: Connected to peers, but not downloading
« Reply #3 on: March 07, 2018, 04:45:17 AM »
Something from here maybe:
http://linuxtracker.org/

This one seems smaller and has lots of seeds and only a few peers:
http://linuxtracker.org/torrents/365b1b24a753d2ade3d79e4c68a6e3c79dbb2546

gizmo_pook

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Connected to peers, but not downloading
« Reply #4 on: March 07, 2018, 04:53:31 PM »
That worked just fine. So what does it mean when other torrents have peers, but just stop downloading?

Thanks

Switeck

  • Forum addict
  • ****
  • Posts: 1114
  • Karma: +75/-0
    • View Profile
Re: Connected to peers, but not downloading
« Reply #5 on: March 07, 2018, 09:46:56 PM »
The other torrents probably have "dead" peers -- ip addresses that no longer have peers running on them, because they stopped the torrents and/or are firewalled.
Some of what you're seeing may be qBT making connection attempts to ips but never fully connecting and downloading/uploading with them.

The peers that show as having >0% of the torrent completed, you're probably really connecting with but disconnect when an error happens with that peer -- either a hashfail, snub-due-to-inactivity, etc.

Try with uTP disabled.

leemarvin

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Connected to peers, but not downloading
« Reply #6 on: March 08, 2018, 12:52:56 AM »
I'm having the same problem

I tried the recommended Linux file, and it downloaded successfully, at max speed.

I then tried a very popular torrent with over 5000 seeds. What happened next
was exactly what's happened with the previous dozen or so torrents:
it starts as usual. For around two minutes, it collects a lot of seeds (30-50),
with download speed rising from 0 to approximately 900 KiB/s.
Then, over the next minute or so, both the number of seeds and the speed
gradually drop to 0 and 0 KiB/s, respectively.

I also tried with uTP disabled, but got same result.
As an experiment, I downloaded all the above torrents with Transmission.
All maintained a healthy amount of seeds, with an average download speed of 700 KiB/s.
All downloaded successfully.

I've got qBittorrent version 4.0.4
Mac OSX 10.13.3

Thanks in advance for your help.

Switeck

  • Forum addict
  • ****
  • Posts: 1114
  • Karma: +75/-0
    • View Profile
Re: Connected to peers, but not downloading
« Reply #7 on: March 08, 2018, 05:37:27 AM »
Sounds like networking hardware failures or software driver errors, and since that's not on Windows I don't know what to do about that...

That or the networking problems in qBitTorrent (and by consequence libtorrent which does the networking in qBT) is seriously screwed up.
One major speed issue on qBT's github issues:
https://github.com/qbittorrent/qBittorrent/issues/7954

sammy5678

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Connected to peers, but not downloading
« Reply #8 on: April 24, 2018, 01:57:46 PM »
I'm having the same problem

I tried the recommended Linux file, and it downloaded successfully, at max speed.

I then tried a very popular torrent with over 5000 seeds. What happened next
was exactly what's happened with the previous dozen or so torrents:
it starts as usual. For around two minutes, it collects a lot of seeds (30-50),
with download speed rising from 0 to approximately 900 KiB/s.
Then, over the next minute or so, both the number of seeds and the speed
gradually drop to 0 and 0 KiB/s, respectively.

I also tried with uTP disabled, but got same result.
As an experiment, I downloaded all the above torrents with Transmission.
All maintained a healthy amount of seeds, with an average download speed of 700 KiB/s.
All downloaded successfully.

I've got qBittorrent version 4.0.4
Mac OSX 10.13.3

Thanks in advance for your help.

Lo and behold, same exact issue welcomed me this morning. Did you ever get it resolved? Thus far, I'm at a total loss.