Author Topic: [official]qBittorrent 4.1.3 installer - Built with MSVC 2017  (Read 6010 times)


  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Re: [official]qBittorrent 4.1.2 installer - Built with MSVC 2017
« Reply #30 on: August 24, 2018, 09:19:47 PM »
EDIT : Evgeny Lensky  has updated the page, and it's working now. Thx a lot.

Ok so, I tried again.
boost 1.68
libtorrent 1.1.9
openssl 1.0.2k
QT 5.9.0
Zlib 1.2.11

In my case, I use c:\qbittorrent instead of g:\qbittorrent. Of course I change the path in each command

EDIT : first step with the zlib, I've errors, a lot of :

MASM : warning A4018:invalid command-line option : -coff       when assembling file

So, If I follow the wiki, the fist warning is  after ms\do_win64a for openssl :

=>unknown option - enable-threads

But google says it's pretty common, so I go on.

Next, after nmake -f ms\nt.mak

I got a lot of "cl : Ligne de commande warning D9025 : substitution de '/Ox' par '/O1'" and "pkeyutl.c
.\apps\pkeyutl.c(350): warning C4267: 'fonction' : conversion de 'size_t' en 'long', perte possible de données"
(possible data loss)

Then, with the command :

b2 -q --with-system --toolset=msvc-15.1 address-model=64 variant=release link=static runtime-link=static include="C:\QBITTORRENT\install_msvc64\base\include" library-path="C:\QBITTORRENT\install_msvc64\base\lib" --prefix="C:\QBITTORRENT\install_msvc64\base" cxxflags="-O1 -Gy -Gw -GL" linkflags="/NOLOGO /DYNAMICBASE /NXCOMPAT /LTCG /OPT:REF /OPT:ICF /MANIFEST:EMBED /INCREMENTAL:NO" --hash -j 6

I've some skipped <pstage\lib>libboost_system-vc151-mt-s-1_68.lib for lack of <pbin.v2\libs\system\build\badf2a7c2adcaef3b3bd2286eed781aa>libboost_system-vc151-mt-s-1_68.lib... along the way.

And when building libtorrent :

b2 -q --without-python --toolset=msvc-15.1 address-model=64 variant=release link=static runtime-link=static debug-symbols=on encryption=on crypto=openssl logging=off resolve-countries=off dht=on character-set=unicode boost-link=static -sBOOST_ROOT="C:\qBittorrent\boost_1_68_0" include="C:\QBITTORRENT\install_msvc64\base\include" library-path="C:\QBITTORRENT\install_msvc64\base\lib" --prefix="C:\QBITTORRENT\install_msvc64\base" cxxflags="-O1 -Gy -Gw -GL" define=BOOST_ASIO_DISABLE_CONNECTEX linkflags="/NOLOGO /DYNAMICBASE /NXCOMPAT /LTCG /OPT:REF /OPT:ICF /MANIFEST:EMBED /INCREMENTAL:NO" --hash -j 6

So, I corrected the ssl settings, but if I put the boost parameter, I've :

boost=source not know

After that :

configure -prefix C:\QBITTORRENT\install_msvc64\qt5 -I C:\QBITTORRENT\install_msvc64\base\include -L C:\QBITTORRENT\install_msvc64\base\lib -platform win32-msvc -release -opensource -confirm-license -strip -no-shared -static -static-runtime -ltcg -make libs -make tools -nomake examples -no-compile-examples -no-dbus -no-qml-debug -no-icu -system-zlib -openssl-linked -no-gtk -no-opengl -no-opengles3 -no-angle -no-sql-sqlite -no-sql-odbc -no-sqlite -skip qt3d -skip qtactiveqt -skip qtandroidextras -skip qtcanvas3d -skip qtcharts -skip qtconnectivity -skip qtdatavis3d -skip qtdoc -skip qtgamepad -skip qtgraphicaleffects -skip qtimageformats -skip qtlocation -skip qtmacextras -skip qtmultimedia -skip qtnetworkauth -skip qtpurchasing -skip qtquickcontrols -skip qtquickcontrols2 -skip qtremoteobjects -skip qtscript -skip qtscxml -skip qtsensors -skip qtserialbus -skip qtserialport -skip qtspeech -skip qtvirtualkeyboard -skip qtwayland -skip qtwebchannel -skip qtwebengine -skip qtwebsockets -skip qtwebview -skip qtx11extras -skip qtxmlpatterns ZLIB_LIBS="-lzlib" OPENSSL_LIBS="-llibeay32 -lssleay32"


jom -j 6

My only warning seems : Generated 457 translation(s) (0 finished and 457 unfinished)

Then, I install QT Creator 4.3.1. When I import the Kits, it warns me about the ABI : QT kits :
Nom :
Qt 5.9.0 (qt5)

But, ok, I go on.

Then, all is alright, until I try to adapt the path in Since I used boost 1.68 , my guess is libboost_system-vc140-mt-sgd-1_64.lib is not right, and I should put the name of the file I should find in C:\qbittorrent\boost_1_68_0\stage\lib at this stage right ? Should look like libboost_system-vc151-xxx1_68.lib or something. Well, my C:\qbittorrent\boost_1_68_0\stage\lib is empty, like boost never builds correctly.

The file is not in C:\qbittorrent\install_msvc64\base\lib  either. (i've 3 lib file here, libeay32.lib ; ssleay32.lib and zlib.lib)

But nothing there :
LIBS += $$quote(-LC:/qBittorrent/boost/stage/lib)
LIBS += $$quote(-LC:/qBittorrent/libtorrent/lib)
LIBS += $$quote(-LC:/qBittorrent/zlib/lib)
LIBS += $$quote(-LC:/qBittorrent/openssl/lib)

Without that, I don't even try to go further in QT Creator, I guess It would be pointless...

EDIT : If i continue with the wiki, the compilation fail at this step :

linking release\qbittorrent.exe
LINK : fatal error LNK1181: impossible d'ouvrir le fichier en entrée 'libtorrent.lib'
jom: C:\qbittorrent\build\src\Makefile.Release [release\qbittorrent.exe] Error 1181
jom: C:\qbittorrent\build\src\Makefile [release] Error 2
jom: C:\qbittorrent\build\Makefile [sub-src-make_first] Error 2
13:12:34: Le processus "C:\Qt\qtcreator-4.3.1\bin\jom.exe" s'est terminé avec le code 2.
Erreur lors de la compilation/déploiement du projet qbittorrent (kit : Qt5 msvc2017 x64)
The kit Qt5 msvc2017 x64 has configuration issues which might be the root cause for this problem.
When executing step "Make"

So any update would be appreciated : /

Thx a lot.


Since the builds are compiled with MSVC 2017, is it possible to update this page please ?

I follow this guide, and some stuff doesn't work anymore with the new versions. I don't have a list of error (way to many...) but in the end you always have errors with this "wiki" in qt creator, and the problem seems to lie into the qt version you build during all the process (no surprise here).

Granted I'm not a dev, but I would like sometime to build my own qbittorrent test version, with new builds of libtorrent or modified settings in qbittorrent source without create an "issue" on github...
« Last Edit: August 25, 2018, 05:54:51 PM by Rootax »


  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: [official]qBittorrent 4.1.2 installer - Built with MSVC 2017
« Reply #31 on: August 26, 2018, 12:21:43 AM »
I give up. I've already spent 15+ hrs trying to compile this thing. I thought all was going well until I get to actually compiling with Qt Creator & I get tons and tons of errors. The tutorial is not written very friendly whatsoever. I've compiled plenty of other projects perfectly fine so following directions isn't the problem. It's a poorly written guide and needs to be redone.

Edit: Mainly I feel what needs to be done is listing what additional modules need to be installed during the MSVC 2017 x64 setup. The guide states "The MSVC 2017 compiler. The Community Edition(free) will do fine.", but does not make any mention of the additional boxes that need to be checked during setup to ensure everything will work properly. The default installation will NOT work.

Secondly, the guide states "latest version of openssl", which if a user does in fact use the latest version (1.1.x), it will result in an error due to starting with 1.1.0 there are no more ms\do_*.bat files. The latest 1.0.2 version needs to be used.

Third, "Install and Configure Qt Creator" needs fixing. The dialoge boxes/layout have evidently changed since the guide was written. For example:

Select the Build & Run item from the left and select the Qt Versions tab.
Click the Add... button and select the qmake.exe you just build. It should be in G:\QBITTORRENT\install_msvc64\qt5\bin\qmake.exe

But there is no Qt Versions tab under Build & Run, hense also no "Add" button there to click on.

There may have been other changes as well, but I can't remember for sure. The entire section could be re-written with more precise steps inb correlation to the changed layout/tabs in 4.7.0.

Lastly, the Compiling qBittorrent section needs some fixes as well. "If you are compiling qBittorrent v3_3_x branch, open the winconf.pri file and adjust the paths. If v4_0_x branch is used, open, save it as conf.pri and adjust the paths."

What about 4_1_x branches?

"If you are compiling v4_0_x branch against libtorrent 1.0.x, uncomment the following line in conf.pri"

No changes needed for 1.1.x?
« Last Edit: August 26, 2018, 01:19:35 AM by parry_hotter »


  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Re: [official]qBittorrent 4.1.2 installer - Built with MSVC 2017
« Reply #32 on: August 26, 2018, 07:46:16 AM »
Yeah, you need 1.0.2.

1.0.2k if you want the wiki version.

For the Microsoft 2017 VS, using the defaut setup when you choose desktop c++ application (something like that) is enough.

For the Qt creator version, use 4.3.1 and you will find the options back where they are.

For the last part, use (then rename it like it says on the wiki). The commented / uncommented BOOST lines are already good with the 4.1.x source version.

You just have to adjust paths, comment the unwanted one (the wiki is right about that), and do the CONFIG(debug, debug|release) {
     LIBS += libtorrentd.lib \
 else {
     LIBS += libtorrent.lib \

thing, so the filenames are ok.

I compiled 2 versions in 16 hours (one with O1 flags like in the wiki, another with O2) both are working fine.

Oh, and yes, for the libtorrent compilation :

b2 -q --without-python --toolset=msvc-14.1 address-model=64 variant=release link=static runtime-link=static debug-symbols=on encryption=on logging=of resolve-countries=off dht=on character-set=unicode boost-link=static -sBOOST_ROOT="G:\QBITTORRENT\boost_1_68_0" include="G:\QBITTORRENT\install_msvc64\base\include" library-path="G:\QBITTORRENT\install_msvc64\base\lib" --prefix="G:\QBITTORRENT\install_msvc64\base" cxxflags="-O1 -Gy -Gw -GL" define=BOOST_ASIO_DISABLE_CONNECTEX linkflags="/NOLOGO /DYNAMICBASE /NXCOMPAT /LTCG /OPT:REF /OPT:ICF /MANIFEST:EMBED /INCREMENTAL:NO" --hash -j %NUMBER_OF_PROCESSORS%

an F is missing, should be logging=off  with "of", it won't compile correctly so the other steps will fail at one point . You can add crypto=openssl  too, to force the use of openssl instead of the buildin one.


  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: [official]qBittorrent 4.1.2 installer - Built with MSVC 2017
« Reply #33 on: August 26, 2018, 09:35:59 AM »
The guide should be edited to reflect everything in the last couple of posts. ;)


  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: [official]qBittorrent 4.1.2 installer - Built with MSVC 2017
« Reply #34 on: September 05, 2018, 12:06:47 PM »
Well, Everyone here is quite advanced with qB and generally. I've been using qB for a while now. I learned early on to 'not' upgrade. I just had too much trouble, for whatever reason (which others could have guessed perhaps) and found that if the program was working, Why did I need the grief?

I just got a new laptop and I'm having a harder time than I've ever had with qB. I watched a dozen YouTube vids, most which were unwatchable. Nothing here clues me in. One YouTube vid I watched showed how to simply click on search via view and it would automatically download python, which I'm missing. It worked great for him. I just got a msg saying that my python version is unknown. But if I don't have it, Isn't that a meaningless statement? At this point, I'm going to either get an answer from someone here that I can understand or just try downloading another qB because I'm certainly never going to use utorrent again.

Sorry to be whiney. Thanks in advance.

ASUS VivoBook, windows 10, 64 bit.


  • qBittorrent maintainer
  • Administrator
  • Forum addict
  • *****
  • Posts: 2397
  • Karma: +148/-1
    • View Profile
Re: [official]qBittorrent 4.1.2 installer - Built with MSVC 2017
« Reply #35 on: September 19, 2018, 01:37:48 AM »
Here is qBittorrent 4.1.3 built with MSVC 2017.

4.1.3 link->

Libraries's version used:
Libtorrent: 1.1.9+git8cc93e9855
Qt: 5.6.3 (32-bit) / 5.11.1 (64-bit)
Boost: 1.68.0