Author Topic: I/O error  (Read 806 times)

cybermcm

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
I/O error
« on: June 02, 2018, 11:18:54 PM »
Hello,

Not sure if this is a bug so I'm posting it here maybe help is out there?
Using qBittorrent in portable mode (virtual Windows Server 2016, KVM). Reproduceable: Download is either ready or downloading -> reboot -> qB throws an error message with all downloads (regardless which download)
Log file: "An I/O error occurred, error: The filename, directory name, or volume label syntax is incorrect"

The file itself is healthy and working...

Any ideas?

cybermcm

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: I/O error
« Reply #1 on: June 14, 2018, 08:56:42 AM »
Another update. This also happens without reboot, just closing and opening qb throws the error msg (example download)
"An I/O error occurred, 'Zeitung' paused. Zeitung stat (../../../../DL\Zeitung\BI_140618.pdf) error: The filename, directory name, or volume label syntax is incorrect"

The file is ready and working.
Any ideas?

Switeck

  • Forum addict
  • ****
  • Posts: 1172
  • Karma: +79/-0
    • View Profile
Re: I/O error
« Reply #2 on: June 14, 2018, 10:00:09 AM »
qBitTorrent 32bit version with its disk cache (in advanced) set to -1 (automanaged) or >1000 MB? If so, that's something I discovered awhile back:
http://qbforums.shiki.hu/index.php/topic,2042.0.html

There might be other I/O issues, even recent ones like this:
https://github.com/qbittorrent/qBittorrent/issues/9056
...at qBitTorrent's github issues webspace:
https://github.com/qbittorrent/qBittorrent/issues/

cybermcm

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: I/O error
« Reply #3 on: June 14, 2018, 11:37:18 AM »
all advanced settings are default values, disk cache is set to 64 MiB

The other issues you mentioned are similar but I've a different error message: "The filename, directory name, or volume label syntax is incorrect"

Mike_EE

  • Newbie
  • *
  • Posts: 19
  • Karma: +1/-0
    • View Profile
Re: I/O error
« Reply #4 on: June 14, 2018, 02:43:23 PM »
There are at least three issue tickets on this issue, or other very similar issues:

https://github.com/qbittorrent/qBittorrent/issues/9028
https://github.com/qbittorrent/qBittorrent/issues/9038

The first ticket - 9028 - is almost two weeks old without comment from the development team. This is a major defect, and I hope that it's being looked at.

cybermcm

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: I/O error
« Reply #5 on: June 14, 2018, 05:26:03 PM »
The issues have the same general error message "I/O error" but a slightly different detailed error: "The filename, directory name, or volume label syntax is incorrect"
This error exists since a few weeks (maybe months) for my system, it is definitely not related to the last version (I think it started with a 4.x version but I didn't spend enough attention to pinpoint the exact version)...

Mike_EE

  • Newbie
  • *
  • Posts: 19
  • Karma: +1/-0
    • View Profile
Re: I/O error
« Reply #6 on: June 18, 2018, 12:36:57 PM »
These I/O issues seem to be caused by one or more bugs in libtorrent, which have developer attention and are being addressed:

https://github.com/arvidn/libtorrent/pull/3110

cybermcm

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: I/O error
« Reply #7 on: June 18, 2018, 01:12:14 PM »
Thank you for this information. I hope that this bug gets resolved soon, it's annoying (at least for me). After every reboot my torrents are broken... Currently switching to Āµtorrent for the time...
But I'll watch closely every version and test...

cybermcm

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: I/O error
« Reply #8 on: August 13, 2018, 09:38:16 PM »
Version 4.1.2 is out, still same error here :-( file downloads correctly, if I close and reopen QB I get the I/O error...

Ryrynz

  • Member
  • **
  • Posts: 45
  • Karma: +0/-6
    • View Profile
Re: I/O error
« Reply #9 on: August 15, 2018, 09:25:42 AM »
I'd start playing with cache settings..

cybermcm

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: I/O error
« Reply #10 on: August 15, 2018, 10:21:04 AM »
maybe you can be more specific?
I didn't touch any cache or advanced settings, isn't it supposed to work out of the box? It worked until a specific version (which I sadly can't pinpoint)...

Mike_EE

  • Newbie
  • *
  • Posts: 19
  • Karma: +1/-0
    • View Profile
Re: I/O error
« Reply #11 on: August 15, 2018, 02:14:05 PM »
I have the same problem even the problem ejecting USB mass storage device issue need to fix!

Are you sure that qBT was finished writing files when you ejected the USB drive?

Mike_EE

  • Newbie
  • *
  • Posts: 19
  • Karma: +1/-0
    • View Profile
Re: I/O error
« Reply #12 on: August 15, 2018, 02:17:31 PM »
Version 4.1.2 is out, still same error here :-( file downloads correctly, if I close and reopen QB I get the I/O error...

Can you post the exact error message?

cybermcm

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: I/O error
« Reply #13 on: August 15, 2018, 04:37:00 PM »
It's always the same error message, see above
https://qbforums.shiki.hu/index.php?topic=6005.msg28508#msg28508