Author Topic: Using IPv6 and IPv4  (Read 1362 times)

scrappy

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Using IPv6 and IPv4
« on: June 05, 2018, 05:52:58 am »
G'day all ...

    I have qBittorrent v4.1.1 installed and just upgraded my Cable modem to give me both IPv6 and IPv4 networks ... if I go to whatismyip.com, it shows both IPs fine ... if I start seeing a torrent, my tracker shows both IPs ... but, it doesn't show the Port, so can't connect back to me.

   If I look at the logs, it shows:

(N) 2018-06-04T20:23:34 - qBittorrent v4.1.1 started
(I) 2018-06-04T20:23:34 - qBittorrent is trying to listen on any interface port: 18874
(N) 2018-06-04T20:23:34 - Peer ID: -qB4110-
(N) 2018-06-04T20:23:34 - HTTP User-Agent is 'qBittorrent/4.1.1'
(I) 2018-06-04T20:23:34 - DHT support [OFF]
(I) 2018-06-04T20:23:34 - Local Peer Discovery support [OFF]
(I) 2018-06-04T20:23:34 - PeX support [OFF]
(I) 2018-06-04T20:23:34 - Anonymous mode [OFF]
(I) 2018-06-04T20:23:34 - Encryption support [ON]
(I) 2018-06-04T20:23:34 - Embedded Tracker [OFF]
(I) 2018-06-04T20:23:34 - GeoIP database loaded. Type: GeoLite2-Country. Build time: Tue May 1 09:47:28 2018.
(N) 2018-06-04T20:23:34 - Web UI: Now listening on IP: *, port: 46927
(N) 2018-06-04T20:23:35 - Options were saved successfully.
(I) 2018-06-04T20:23:36 - qBittorrent is successfully listening on interface :: port: TCP/18874
(I) 2018-06-04T20:23:36 - qBittorrent is successfully listening on interface 0.0.0.0 port: TCP/18874
(I) 2018-06-04T20:23:36 - qBittorrent is successfully listening on interface 0.0.0.0 port: UDP/18874
(I) 2018-06-04T20:23:38 - External IP: <IPv4 IP>
(N) 2018-06-04T20:23:39 - RSS feed at 'https://www.shazbat.tv/rss/followed?passkey=d7172247030a0ec85ddf968cf2a124480cab79d6&amp;tag=.mkv,Season+.mkv' updated. Added 0 new articles.
(N) 2018-06-04T20:23:39 - RSS feed at 'https://shazbat.tv/rss/download_queue?passkey=d7172247030a0ec85ddf968cf2a124480cab79d6' updated. Added 0 new articles.
(I) 2018-06-04T20:23:59 - External IP: <IPv6 IP>


So its trying to listen on the right port, and its finding both external IPs ... but the tracker is only seeing the IPs, not the port ...

If I go into Advanced Settings and bind to the interface that both of the IPs are bound to, the logs then show:

===
(N) 2018-06-04T20:26:46 - qBittorrent v4.1.1 started
(I) 2018-06-04T20:26:46 - qBittorrent is trying to listen on interface fe80::143e:222:43b6:6e7a%en1 port: 18874
(N) 2018-06-04T20:26:46 - Peer ID: -qB4110-
(N) 2018-06-04T20:26:46 - HTTP User-Agent is 'qBittorrent/4.1.1'
(I) 2018-06-04T20:26:46 - DHT support [OFF]
(I) 2018-06-04T20:26:46 - Local Peer Discovery support [OFF]
(I) 2018-06-04T20:26:46 - PeX support [OFF]
(I) 2018-06-04T20:26:46 - Anonymous mode [OFF]
(I) 2018-06-04T20:26:46 - Encryption support [ON]
(I) 2018-06-04T20:26:46 - Embedded Tracker [OFF]
(I) 2018-06-04T20:26:46 - GeoIP database loaded. Type: GeoLite2-Country. Build time: Tue May 1 09:47:28 2018.
(N) 2018-06-04T20:26:46 - Web UI: Now listening on IP: *, port: 46927
(N) 2018-06-04T20:26:47 - Options were saved successfully.
(I) 2018-06-04T20:26:48 - qBittorrent is successfully listening on interface fe80::143e:222:43b6:6e7a%en1 port: TCP/18874
(I) 2018-06-04T20:26:48 - qBittorrent is successfully listening on interface fe80::143e:222:43b6:6e7a%en1 port: UDP/18874
(I) 2018-06-04T20:26:49 - External IP: <IPv4 IP>
(N) 2018-06-04T20:26:50 - RSS feed at 'https://shazbat.tv/rss/download_queue?passkey=d7172247030a0ec85ddf968cf2a124480cab79d6' updated. Added 0 new articles.
(N) 2018-06-04T20:26:51 - RSS feed at 'https://www.shazbat.tv/rss/followed?passkey=d7172247030a0ec85ddf968cf2a124480cab79d6&amp;tag=.mkv,Season+.mkv' updated. Added 0 new articles.


So now it finds the IPv4 IP, and my tracker shows it and the port ... but it doesn't find the IPv6 anymore, and they are both bound to the same interface ...

No matter what I do, I can't seem to get it to bind / announce on both IPv4 and IPv6 .... so I figure I have to be missing something ...

Anyone out there with luck on this?

scrappy

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Using IPv6 and IPv4
« Reply #1 on: June 05, 2018, 07:54:45 am »
Fixed ... in a sense ... downgraded to bwright's v4.0.2, problem all cleared up ... *shrug*


Switeck

  • Forum addict
  • ****
  • Posts: 1467
  • Karma: +93/-0
    • View Profile
Re: Using IPv6 and IPv4
« Reply #2 on: June 05, 2018, 09:41:32 am »
Using IPv4 and IPv6 at the same time right now with qBitTorrent seems difficult-to-impossible due to bugs.

qbittorrent announce an invalid port "0" to tracker    https://github.com/qbittorrent/qBittorrent/issues/8606
"Tracker functions when only an IPv4 address is used, and fails when both 4 and 6 are assigned."

Which sounds vaguely like these problems:
The port reported to Tracker will be "0" even the proxy and anonymous mode are both turned off.    https://github.com/qbittorrent/qBittorrent/issues/8733
[Bug] Enabling proxy in the settings causes incoming port=0    https://github.com/qbittorrent/qBittorrent/issues/5445