Author Topic: qbittorrent 4.1.6 not working crashes on startup on Windows XP x64  (Read 4426 times)

Kars (1934)

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
I have upgraded qbittorrent 4.1.5 to qbittorrent 4.1.6 a few days ago. I have noticed that most of the times I open it it just crashes. It shows me the "Application not responing" window and makes me choose between closing it and online help.
Some other times instead it opens and appears to be working fine, but this happens without an apparent reason and very rarely. Once I close it it is back to startup crash.
I have tried:
Closing it and opening it again;
Shutting down and rebooting the computer;
Reinstalling the application;
Terminating the antivirus processes and reinstalling the app;
Opening qbittorrent with admin privileges.
But none of this has had any result.
I am running on Windows XP x64. My computer is very old, but I have noticed other people here have the same problem with the new version as well.
I would be grateful if you could provide me with any help.
Thank you.

EDIT #1: I have managed to open qbittorrent and keeping it opened for several hours without ever closing it. I have downloaded a 900+MB torrent, which I verified to be integer (it is a video). Upload and download thus seem to be workig fine (I have also uploaded 600+MB of data in this session), which makes me guess there is no problem of compatibility with my OS nor of internal functioning of the app. It should be just a problem with the initialization of qbittorrent.

EDIT #2: After over 1GB of upload I closed qbittorrent, and as expected I wasn't able to open it again for a few times. I got the usual message "qbittorrent.exe stopped working". On the fifth/sixth attempt it successfully opened and started uploading without crashing. After this I closed it and got back to the same problem of not being able of predicting when it will work.
I also tried changing in C:\Users\<username>\AppData\Roaming\qBittorrent\qBittorrent.ini the string "DownloadTrackerFavicon=true" into "DownloadTrackerFavicon=false" but the problem didn't change.


I am reporting this although I know there are more skilled people working on this issue on https://github.com/qbittorrent/qBittorrent/issues/10581 and it seems the problem might be in something related to MySQL.
« Last Edit: May 12, 2019, 12:41:13 am by Kars (1934) »

Switeck

  • Forum addict
  • ****
  • Posts: 1467
  • Karma: +93/-0
    • View Profile
Re: qbittorrent 4.1.6 not working crashes on startup
« Reply #1 on: May 11, 2019, 09:34:57 am »
The qBittorrent and libtorrent devs probably would be helped if they could find the common cause/s to the crashes.

Although it seems there's been lots of posts on the subject here:
https://github.com/qbittorrent/qBittorrent/issues/10581   4.1.6 not working on my Windows 10

PS: I wouldn't recommend running qBitTorrent 64bit version on that older OS, due to qBitTorrent probably expecting Win 7 and later when using 64bit.

hey

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: qbittorrent 4.1.6 not working crashes on startup
« Reply #2 on: May 11, 2019, 12:56:46 pm »
I'm using the latest version of Windows 10 1809 x64 with all patches applied and ever since I installed 4.1.6 I'm facing the same issue. The crashes in the last 5 days in the reliability history (see screenshot) are all qbittorrent.exe. I guess I'm going back to the former version until this is fixed.

https://i.imgur.com/TmErZM2.png

shgth

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: qbittorrent 4.1.6 not working crashes on startup
« Reply #3 on: May 11, 2019, 03:11:12 pm »
I'm having this same problem with the latest(4.1.6). Nothing helped other than going back to 4.1.5.. It worked for first but stopped staying launched just an hour ago.
 
OS: Windows 10 1809 x64

Kars (1934)

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: qbittorrent 4.1.6 not working crashes on startup
« Reply #4 on: May 11, 2019, 06:06:20 pm »
The qBittorrent and libtorrent devs probably would be helped if they could find the common cause/s to the crashes.

Although it seems there's been lots of posts on the subject here:
https://github.com/qbittorrent/qBittorrent/issues/10581   4.1.6 not working on my Windows 10

PS: I wouldn't recommend running qBitTorrent 64bit version on that older OS, due to qBitTorrent probably expecting Win 7 and later when using 64bit.

I understand what you say, I am reporting it because of this weird behavior.
Moreover, the fact that it does function at times means there are no problems with the nature of the OS. I have kept it open for several hours now and it has given me no problems. I have downloaded a 900+MB torrent. However if I do close qbittorrent I probably won't be able to open it again.

hey

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: qbittorrent 4.1.6 not working crashes on startup on Windows XP x64
« Reply #5 on: May 11, 2019, 08:44:43 pm »
I've installed the version https://builds.shiki.hu/temp/qbittorrent_4.1.6_x64_for_issue_10581_v3.7z which was referenced here https://github.com/qbittorrent/qBittorrent/issues/10581 and I have made sure the mentioned ini entry is set to false (in my case it already was) - no effect so far. So I just reverted to 4.1.5. The fact that the new build does nothing for me worries me a little bit, since some people over there claim it helped them. But what can I do, I'll just wait. 4.1.5 works the way it should and there aren't any big reasons to update right now.

gspbeetle

  • Member
  • **
  • Posts: 20
  • Karma: +1/-0
    • View Profile
Re: qbittorrent 4.1.6 not working crashes on startup on Windows XP x64
« Reply #6 on: May 15, 2019, 04:25:12 pm »
Same, auto shutdown on Windows 10 after a few days using 4.1.6 at startup and the 'fix' does not work either.
Happens when memory build up to around 2300-2400mb (on 4.1.5 qB uses >3000mb memory).
Download to 4.1.5 and works fine again, so the database is not corrupted.
Most likely related when running qB with alot of tasks (thats probably the reason why we need x64 anyway).
« Last Edit: May 15, 2019, 04:28:55 pm by gspbeetle »