Author Topic: qbittorrent-nox - random torrents fastresume gets corrupted and causes hang  (Read 381 times)

pyr0ball

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
hey guys, I'm running into a weird issue with my qbittorrent-nox 4.1.6 instance. running on ubuntu server 16.04, working fine up til I rebooted my server this week. Behavior is that the page just sits waiting to load. Chrome and firefox both showing the same behavior. Developer console network just says "pending". if I kill the service, it gives me an expected error, but when it's on it's just loading.

I thought maybe it was trying to run an extract on a big torrent or something so I disabled the external post-download script, but that had no effect.

Eventually I started poking around in the fastresume files thinking one of the torrents had gotten corrupted (I've seen that behavior with rtorrent in the past) and it turned out that was the cause.

When qbit is in a bad state, the service appears to be running fine, and I'm seeing no errors in the logs other than a couple of "files missing torrent has been paused" outputs.

In order to identify the torrents causing the hang I ended up having to move all the fastresume files out of ~/.local/share/data/qBittorrent/BT_backup and move them back in batches til I narrowed the issue down to the faulting torrent. Very tedious process when there's 700+ torrents in there.

Anyhoo, I'm wondering if there's a way I could either get more debug output from qbit so I can more quickly identify faulty resumedata, or maybe some way of scripting the process so I don't have to spend an hour doing this when it happens? (This has happened three times now since the first instance)

I'm not sure if this is a bug or not but I'd be happy to open an issue on the github if it's determined that it is.

Thanks in advance!