Recent Posts

Pages: [1] 2 3 ... 10
1
Windows / Re: Migrate from uTorrent to qBittorrent easily
« Last post by Nemo on Today at 02:07:08 AM »
Welcome nickarad, thanks for the kind words.

I would love to help you out and give you step by step instructions on how to use this migrate tool but its been a while (first post is from March 2015) I have read this topic and can't remember the exact steps in order to get this working. I never used or tried it myself.

However you can read the first post that has some instructions written over here: https://qbforums.shiki.hu/index.php/topic,3224.msg15518.html#msg15518

Quote
Some usage information as you asked for it:

- Close both uTorrent and qBittorent
- Open a command prompt from Start menu
- Run ut2qt.exe (or the ruby script) with two command line parameters. First one is the full path and filename of uTorrents resume.dat (usually C:\Users\<username>\AppData\Roaming\uTorrent\resume.dat). The second parameter is the path to qBittorrents BT_backup folder (usually C:\Users<username>\AppData\Local\qBittorrent\BT_backup\)
- Wait for the program to end, then start qBittorrent

Or if someone that has used this tool can write down some more information would be nice perhaps.

Do you need to transfer alot of torrents or just a few? If few you can add the torrent files into qBittorrent, choose the right location of the files and recheck them.

I also opened an issue at Github: https://github.com/qbittorrent/qBittorrent/issues/7135. Just an idea but lets see how the devs think about it about something more official tool like thing.
2
Linux / Request to improve the UPnP of qB
« Last post by JackMegatron on Today at 12:53:17 AM »
Hey. Mega cool, to be here.  8) ::)

According to one's own Internet Provider, respectively mostly, according to ROUTER (!) type, Qbittorrent and ALL Filesharing Clients on Linux (unlike on windows, AND unlike Amule on Linux, even!) might in certain cases need a rather complicated and by the user her- or himself then in the cases, where needed (Qbittorrent under Linux, as direct PC host or in Virtualbox, same case!), router-intrusive, router-configurative "port-forwarding" respectively port-opening, it's called in some routers "give free/share/allow access to ports".

Therefore, when moving to another apartment, or when changing one's internet service provider or router, such a router-configuration by the user is needed - yet NOT at all (!) for Amule, where it does not matter, if the connection indicator symbol arrows are merely yellow and not green, which shows, that Amule (and Emule) has a more sophisticated, differently built net-system, - seen so by comparison to qBittorrent, from the view of a user, who is not dumb, and who can merely see, in qB's log, which ports the program needs and could connect to or not.

Of course, "pglgui", Peerguardian, and also "gufw", the two best firewalls for Linux, are also important.

The result in my case is, that new routers of most providers, need configuration sadly, to give qB access.

I got now, by some port-opening by me within my router, actually a green symbol for connections in qB, yet the search MERELY finds the Demonoid search engine, and not ANY others. Also, the update button for the search engines gives the (wrong) error message, that the update server would "temporarily not be available", which shows, my qB still has not the correct connection.

I didn't only do port openings for really "all" ports, which qB needs, shown by the "sockinfo" command, the "procinfo" program on linux, which shows, which ports running programs use or need. Should I define anywhere port ranges?

I also, moreover, did those port openings for both qB and for UPnP, within GUFW.

When I now restart my qB (within Virtualbox on Ubuntu, bridged networking, should work perfectly, always did, bridged net is better than NAT, since the host then doesn't need to be opened up by Peerblock, if the host is a win sys, yet I DID now even open up in Peerblock on my host sys, that by surely lots of users at first mistrusted 239.255.255.255 adress.

Anyway, when I restart the qB within the Virtualbox Ubuntu system, which is freshly installed and perfectly configured by me, then, the qB shows an error msg, the by qB connected-to IP would "already be in use", which I don't yet understand, could be a redundant, "too much" of port-opening in the router, I estimate. That shouldn't happen, of course. Restarting qB itself, should be no problem. Anyway, the first start of qB is insofar successful, more than nothing, by the DHT, which now correctly connects to around 380 nodes, which IS great already.

Yet as said, I only funnily got access now in searches, to only Demonoid, yet all the search engines should be accessed by any search.

Even without UPnP, qB could connect perfectly, exactly like Amule does.

I already requested the actually exact same thing, well, a bit of a different thing, that qB should connect via WLAN, which was several years ago, which I clearly saw, was the reason back then for actually Utorrent's non-connection, even on win, back then, when connecting via WLAN. It got taken up, yet the UPnP module and better-said, the entire connection module of Uttorent of course, was improved, - which does not relate to Qbittorrent, LOL :) I simply wanted here to again say a HUGE thank You also to the Utorrent makers, which took up my request EXTREMELY quickly, and it worked after a mere FIVE DAYS after my request, about which I was extremely positively STUNNED really, very astounded.

It's important, to translate things correctly, from tech-experience, by anyone, into what is the problem, a description of that.

Here, the simple concern of mine, I am PC-Supporter, is, that Users should NOT be required, to "mess" with, to configure anyhow, their router, which can lead to loss of internet connection, which DID even happen to me. Routers in cases don't like some stuff, namely the disablement of remote control, which must inside the LAN, still be left open. Most users wouldn't know, what to change in their router, and what not, and how to correctly change, configure, whenever, needed port openings.

qB CAN connect, without any port-forwarding, even without UPnP, already now, with some "tweaking" by its own makers. As for now, enabling UPnP in one's own router, is a good method, to get the DHT icon to turn green, within qB, yet I don't know yet, how to "enable", to make connect, the search engines of qB.

It's a two-fold story: I need to know, how to connect, how to make qB connect, and I want to put out this request, to pre-configure qB, to run without any router-configuration, and also without UPnP, since UPnP is a security risk for the router, which my router explicitely told me, when turning on the UPnP, and I am technically not so "happy" about turning on UPnP.

It's simply much more secure, to download by a filesharing client ONLY within a linux system, be that as a host system, or as a guest system in virtualbox, which makes exactly NO difference, host or guest system. And people DO mostly NEED a win sys, as host, since most apps run only on win, of course.

That amule can connect "fully" (=also yellow connection symbol, not only green!), without any router configuration, and qB not, is "the thing", the problem, which CAN be improved.

For now, the needed port-forwardings/openings in the router and in pglgui and in gufw, are surely a "tread-down", a lowering, of security of the system.

Until qB can connect "just like this", without anything ado, I am VERY thankful, for hints, how to "correct" my search-connection problem in qB, so I know, how to deal with this problem correctly. I hope, qB will soon need no router configuration anymore. It's important for the survival of self-education globally, actually.

Thanks so much for your cherished Replies, blessed be Ye, my great Robotlords Nerds.
3
Linux / WebUI - ERR_EMPTY_RESPONSE
« Last post by Eriol on July 20, 2017, 11:31:44 PM »
Hello,

I just updated to 3.3.14 on Linux Mint 17.3 and the WebUI doesn't work anymore.
I got the following message when I try to connect (Chrome):

192.168.1.1 didn’t send any data.
ERR_EMPTY_RESPONSE

Also tried with firefox, page didn't load as well.
I have a * at the Server domains part of the webui config.
And I cannot downgrade because 3.3.13 was removed from the repository already...

Does anyone have any idea how to solve this?
4
Generic / Re: qBittorrent Controller for Android
« Last post by lgallard on July 20, 2017, 07:55:55 PM »
Release 4.5.4
  • Added Host and Referer for subfolder case
  • Changed upload and download order in torrent info to match with the upper bar info.


Available on:

Google Play: qBittorrent Controller Pro  / qBittorrent Controller Free
GitHub: qBittorrent Controller Free
5
Windows / Re: Migrate from uTorrent to qBittorrent easily
« Last post by nickarad on July 20, 2017, 10:59:52 AM »
Mate @ Nemo, please explain me (if you want) the steps I have to make when passing the torrents from utorrent to qbittorent. You being a moderator have seen all the comments on this section. So you are the best able to document. I do not know why the team that designed qbittorent does not put a tutorial or description, inform everyone, if that can be done normally, from Qbittorent software or not. I do not want to try other achievements made by anyone. I only want achievements made by the respective soft producers.That's why I ask you to explain to me if you can move from utorrent to qbittorent torrents, step by step. Thank you in advance.
 Ceao.
6
Windows / reseed moved and renamed files
« Last post by fakerismydad on July 20, 2017, 10:14:50 AM »
It seems like its been an issue for years and i cant find a solution. Probably there is one im missing but still i have too ask for it. Recently i changed to qbt from u torrent and a key feature of seeding is missing.
There is no option to relocate files in a torrent that u already own and u want to reseed but they are in defferent locations and renamed. For example, if there is a torrent that contains the files: f1, f2, f3 and u have downloaded them then deleted the torrent and renamed them to e1, e2, e3 while moving them to other random locations in your pc. When u decide to reseed them in utorrent u can assign manually every file ex: f1 to e1
and then after the recheck it starts seeding without renaming e1 to f1. But in qbt in order to reseed, your files are needed to be is the same folder. If u know a solution please share it!
Thank you in advance.
7
Windows / Re: Firefox magnet links
« Last post by mike20021969 on July 20, 2017, 07:27:52 AM »
Shouldn't exist there an entry with name "magnet" after I installed qBittorrent with those assotiation options checked?
qBittorrent doesn't add the "magnet" entry. If an entry is not there by default, Firefox will/should add it automatically.
More information here: https://support.mozilla.org/en-US/kb/applications-panel-set-how-firefox-handles-files?redirectlocale=en-US&as=u&redirectslug=Options+window+-+Applications+panel&utm_source=inproduct
8
Generic / Re: Translations on Transifex
« Last post by fusk on July 20, 2017, 02:53:33 AM »
sledgehammer_999
Would it be possible to update the about/translators list under the Danish section? I'm just thinking there's one guy mentioned that i have never seen on transifex, might be from before that as i remember that when i joined the team 3 years & 4 months ago i was the only member (besides sledgehammer who had done some google translations) and was so for a long, long time. Just thought that some of the people who have worked on it for the past year might appreciate being mentioned in the translator section.
9
Windows - QA Department / Re: Unofficial 64-bit installer/archive 3.3.x
« Last post by Nemo on July 20, 2017, 02:10:26 AM »
Yes, usage over 1GB of memory while idling 2 torrents or so after some time has passed. Fresh startup climbs very fast over 200MB out of nothing while doing nothing. Thats some huge leak. Otherwise it works very nice.

I can help if testing is needed just let me know.

Edit:

Quote
Could possibly be happening on Linux as well. After going back to libtorrent 1.0 the problem went away.

https://github.com/qbittorrent/qBittorrent/issues/5836

Most likely libtorrent 1.1 related then.

10
Windows - QA Department / Re: Unofficial 64-bit installer/archive 3.3.x
« Last post by sledgehammer_999 on July 20, 2017, 02:05:32 AM »
Discovered this by chance.
I also am observing huge memory usage with the 1.1.x series on Windows. If I limit the cache in the advanced settings it seems to affect it but not by much.
And it is my intention to use 1.1.x for the upcoming v3.4.0 series.
Pages: [1] 2 3 ... 10