qBittorrent official forums

qBittorrent => Linux => Topic started by: wimK on January 09, 2019, 04:40:51 PM

Title: NEWBIE, help please
Post by: wimK on January 09, 2019, 04:40:51 PM

I'm trying to get qBittorrent to work on my Raspbian Pi3b+ running stretch.
I can see the webif and I can select a torrent for download, but downloading never starts.
I've run into a couple of issues I have been able to fix, but not this one (see below) which might be the cause of my problem:

./configure --prefix=/usr --disable-gui --enable-python-binding --with-libgeoip --with-libiconv --with-boost-libdir=/usr/lib/arm-linux-gnueabihf --with-qt4

I get:
WARNING: unrecognized options: --enable-python-binding, --with-libgeoip, --with-libiconv, --with-qt4

Things I already did before config:
sudo apt-get install libqt4-dev
sudo apt-get install python
sudo apt-get install geoip-database

(now I notice I haven't installed libiconv, but that probably isn't causing the other unrecognized options)

Any help appreciated.
Title: Re: NEWBIE, help please
Post by: wimK on January 09, 2019, 09:38:24 PM

Got it working, eventually. This works:
export LD_LIBRARY_PATH=/usr/local/lib:${LD_LIBRARY_PATH}

1. Is it normal I have to "su" first? Or have I done something wrong?
2. I have to type the export command every time again before starting qbittorrent-nox after closing and opening a new terminal window.
I understand that this is normal behaviour. I tried several ways to make this environment (path to /usr/local/lib) variable permanent.
But why do I have to do this? This path is already set in the system.*1
And I tried different methods to make it permant, but haven't succeeded. What is the appropriate way for raspbian? *2
Do I need it when starting qbittorrent as a service?


*1 https://www.raspberrypi.org/forums/viewtopic.php?t=41871#p339321
*2 /etc/environment /etc/profile; just put in /usr/local/lib?; and then sudo ldconfig
Add the directory to /etc/ld.so.conf or a new file in /etc/ld.so.conf.d/ and then sudo ldconfig