Author Topic: Inhibit system sleep - Not Working - v4.1.2 (64-bit)  (Read 836 times)

Qoncussion

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Inhibit system sleep - Not Working - v4.1.2 (64-bit)
« on: August 18, 2018, 07:50:01 pm »
I searched the forums and could not find a fix for this issue. Kindly direct me to a thread - if you know of one that includes a fix.

I've been using QBT for a couple of years (love it!) and the "Inhibit system sleep" function has always been hit and miss. After an update to version 4.1.2 (64-bit), it has completely stopped working.

Are there any known fixes for this?

Thanks in advance!

=========================================================
INFORMATION:

QBT is currently running with the Inhibit sleep on downloads and uploads options selected.

powercfg.exe /requests:
DISPLAY:
None.

SYSTEM:
None.

AWAYMODE:
None.

EXECUTION:
None.

PERFBOOST:
None.

=========================================================
System Specs:
I am running Windows 8.1 64-bit on AMD FX-9590 Vishera 8-Core 4.7GHz Processor | GIGABYTE GA-990FXA-UD3 AM3+ 990FX Motherboard | SAPPHIRE TRI-X OC Radeon R9 290X 4GB 512-Bit GDDR5 Video Card | G.SKILL Trident X Series 1866 16GB DDR3 RAM | CORSAIR Hydro H105 Liquid CPU Cooler
« Last Edit: August 18, 2018, 07:52:25 pm by Qoncussion »

Qoncussion

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Inhibit system sleep - Not Working - v4.1.2 (64-bit)
« Reply #1 on: August 19, 2018, 10:33:45 pm »
I can see from numerous threads on the web that this is an age old problem that is not at the top of the programmer's to-fix list. It works sometimes, which is like not working at all; shame, as it is a much needed feature.

https://github.com/qbittorrent/qBittorrent/issues/7452

https://github.com/qbittorrent/qBittorrent/issues/7159

https://github.com/qbittorrent/qBittorrent/issues/7019

https://qbforums.shiki.hu/index.php?topic=4272.0

the list goes on and on and on and ........

Qoncussion

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Inhibit system sleep - Not Working - v4.1.2 (64-bit)
« Reply #2 on: October 13, 2018, 05:46:09 pm »
I'm updating my own thread - in case anyone ever stumbles upon this. As of the current version 4.1.3, the inhibit sleep function appears to be working flawlessly 100% of the time - for the first time in its history.

In Windows you can run the following command to verify if qBittorrent is keeping your machine awake:

Quote
C:\Windows\System32\powercfg.exe /requests

oumuamua

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Inhibit system sleep - Not Working - v4.1.2 (64-bit)
« Reply #3 on: March 02, 2019, 07:06:04 am »
It is not working for me in version 4.15 on Windows 10 v1809 and I find it increasingly annoying. It would be such a nice feature if it worked. Filezilla has the feature and it does work. I basically have to turn off auto-sleep when torrenting.

Wow. The captchas on this forum are a total nightmare. 10 minutes of captchas just to make this post.