Fast download but no upload at all

Windows specific questions, problems.
Post Reply
TheFlyingCelt
Newbie
Newbie
Posts: 3
Joined: Sun Sep 20, 2020 10:02 pm

Fast download but no upload at all

Post by TheFlyingCelt »

Hi y'all,
I use qBittorrent for years now and I've never been able to upload. Download works as it should, but no upload, at all. Ports are open on the router, firewall is open, and upload works with any other torrent client.
Why?
Thanks
TheFlyingCelt
Newbie
Newbie
Posts: 3
Joined: Sun Sep 20, 2020 10:02 pm

Re: Fast download but no upload at all

Post by TheFlyingCelt »

Nobody? ???
User avatar
Peter
Administrator
Administrator
Posts: 1897
Joined: Wed Jul 07, 2010 6:14 pm

Re: Fast download but no upload at all

Post by Peter »

Well, do you seed something that people actually need/want?
Mostly all torrents are over-seeded on private trackers.

Try adding a bunch of Linux ISOs and see if that seeds.
TheFlyingCelt
Newbie
Newbie
Posts: 3
Joined: Sun Sep 20, 2020 10:02 pm

Re: Fast download but no upload at all

Post by TheFlyingCelt »

Hi Peter,
yes I tried that and it won't upload. On average only 1 out of 100 users that connect to me actually are able to download.
FranciscoPombal
Member
Member
Posts: 53
Joined: Wed Sep 09, 2020 10:34 pm

Re: Fast download but no upload at all

Post by FranciscoPombal »

TheFlyingCelt wrote: Wed Sep 23, 2020 5:14 pm Hi Peter,
yes I tried that and it won't upload. On average only 1 out of 100 users that connect to me actually are able to download.
It is completely normal that you don't upload a lot on Linux ISOs - they are extremely well seeded. Remember, you will only be able to upload a lot if there exists demand that can be filled by you. If many others are already satisfying the demand, it is normal for each individual contribution to be relatively small.

As for "On average only 1 out of 100 users that connect to me actually are able to download.", you probably mean the temporary peers that appear in the Peers tab every now and then and disappear quickly - those are mostly not even actual clients on the other side - just stray non-BitTorrent connections from bots, etc that don't even make it past the handshake. They are not normal users that you're failing to upload to.
TheFlyingCelt
Newbie
Newbie
Posts: 3
Joined: Sun Sep 20, 2020 10:02 pm

Re: Fast download but no upload at all

Post by TheFlyingCelt »

Hi @FranciscoPombal and thanks for your comment.
I understand what you're saying, I didn't know that. Yet, it seems very strange to me that nobody can ever download from me. Even if I leave any kind of file there available, many or few peers, my upload is always 0. When I tried with other clients I can see that it's transferring to others.
Only a very few times in years I've seen my qBittorrent actually uploading.
There must be something wrong... :-\
Last edited by TheFlyingCelt on Sat Sep 26, 2020 10:10 am, edited 1 time in total.
FranciscoPombal
Member
Member
Posts: 53
Joined: Wed Sep 09, 2020 10:34 pm

Re: Fast download but no upload at all

Post by FranciscoPombal »

TheFlyingCelt wrote: Sat Sep 26, 2020 10:08 am Hi @FranciscoPombal and thanks for your comment.
I understand what you're saying, I didn't know that. Yet, it seems very strange to me that nobody can ever download from me. Even if I leave any kind of file there available, many or few peers, my upload is always 0. When I tried with other clients I can see that it's transferring to others.
Only a very few times in years I've seen my qBittorrent actually uploading.
There must be something wrong... :-\
Well, if you don't upload anything at all, even across multiple torrents, and if you notice that other clients can upload significantly more data on equivalent torrents at similar times on the same machine and network, then there is most likely some issue. Most likely some misconfiguration on your end, probably in qBittorrent.

I would start by checking if the port qBittorrent is listening in is open or not with these services:
https://canyouseeme.org/
https://www.yougetsignal.com/tools/open-ports/
http://www.ipv6scanner.com/cgi-bin/main.py

Then, I would try reproducing the problem with the latest version of qBittorrent with all default settings (backup your existing ones and delete them from the original location before starting qBittorrent). https://github.com/qbittorrent/qBittorr ... s_settings

Once you've tried this, report back.
Post Reply