Qbittorrent 3.2.3 and audio lag

Windows specific questions, problems.
Seltap
Newbie
Newbie
Posts: 3
Joined: Sun Jul 12, 2015 4:25 pm

Re: Qbittorrent 3.2.3 and audio lag

Post by Seltap » Thu Aug 20, 2015 11:54 am

Same thing happened with me too on Windows 10 Pro x64.
For me it is not only happening in combination with qBittorrent, but also in combination with tasks where packets are being sent in rapid manner that is why I am thinking that it is not completely qBittorrent at fault here. I was looking more deeply into it and found out that ndis.sys (Network Driver Interface Specification) and/or tcpip.sys (TCP/IP Driver) is somehow at the fault (keep in mind that both of the drivers is supplied by Windows Update) it is causing huge latency spikes. See the screenshot, screenshot captured while Qbittorrent running and nothing else so network consuming

User avatar
Nemo
Administrator
Administrator
Posts: 1579
Joined: Sat Jul 24, 2010 6:24 pm

Re: Qbittorrent 3.2.3 and audio lag

Post by Nemo » Thu Aug 20, 2015 1:18 pm

I assume that everything was working correct before with Windows 7/8.1, Seltap?
Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.


Image
Image

Seltap
Newbie
Newbie
Posts: 3
Joined: Sun Jul 12, 2015 4:25 pm

Re: Qbittorrent 3.2.3 and audio lag

Post by Seltap » Thu Aug 20, 2015 1:35 pm

Yes, Nemo. Even with the same qBittorrent version.

neXus
Member
Member
Posts: 22
Joined: Thu May 21, 2015 2:48 pm

Re: Qbittorrent 3.2.3 and audio lag

Post by neXus » Thu Aug 20, 2015 5:00 pm

Yep, same for me. 3.2.3 worked with Win7 x64

There is really something wrong with 3.2.3 and W10. Except this audio bug, most of torrent are stalling, slow when retrieving trackers, slow in much everything related with torrent files. Today I put some VST (virtual instruments) to download from private tracker and it's just staying stalled. There are about 5 trackers that are waiting to be announced, but all of them are in state of "not working". So, for my amusement I donwloaded QBit 3.2.1 and it worked.

I will watch in next few days how 3.2.1 will behvae in downloading, trackers...etc. and of course will there be problems with audio bugs.

User avatar
Dayman
Administrator
Administrator
Posts: 343
Joined: Mon Jun 18, 2012 8:12 am

Re: Qbittorrent 3.2.3 and audio lag

Post by Dayman » Thu Aug 20, 2015 5:00 pm

I can definitely confirm this.

I had the same very problem in the days of old when I had uTorrent and Windows XP. The culprit was Comodo Firewll, any heavy network usage will cause sound lag, DPC queue wait time would rise above 1000us. So this usually happens because of a poorly written kernel driver.

Unfortunately the program I used to measure DPC latency doesn't seem to work in Win10. Here's the link anyway http://www.thesycon.de/deu/latency_check.shtml

I would recommend to try disabling Windows Firewall and SmartScreen Filter, maybe this will help.
Building x86_64 stuff on Windows due to Gentoo syndrome.

Jabber: [email protected]
Skype: x.dayman
Irc #[email protected]: Dayman

User avatar
Dayman
Administrator
Administrator
Posts: 343
Joined: Mon Jun 18, 2012 8:12 am

Re: Qbittorrent 3.2.3 and audio lag

Post by Dayman » Thu Aug 20, 2015 5:05 pm

Building x86_64 stuff on Windows due to Gentoo syndrome.

Jabber: [email protected]
Skype: x.dayman
Irc #[email protected]: Dayman

User avatar
Nemo
Administrator
Administrator
Posts: 1579
Joined: Sat Jul 24, 2010 6:24 pm

Re: Qbittorrent 3.2.3 and audio lag

Post by Nemo » Thu Aug 20, 2015 9:49 pm

Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.


Image
Image

neXus
Member
Member
Posts: 22
Joined: Thu May 21, 2015 2:48 pm

Re: Qbittorrent 3.2.3 and audio lag

Post by neXus » Fri Aug 21, 2015 6:44 am

[quote="Nemo"]
neXus, did you tried the latest beta also?

https://qbforums.shiki.hu/index.php/topic,3684.msg18572.html#msg18572
[/quote]

I don't know. Mostly because of "new saving system for torrent progress". I have list of torrents that is huge, mostly graphics + plugins and audio + plugins (self learning :) ), so if I migrate to new version, just for testing...

Before I do, question and a bit of how I setted Qbit to download.

In Download section of Qbit, I've put in a same directory to download: torrent file, actual downloaded files, unfinished...etc. If I migrate to new version and new version has bugs, or other things that can be problematic, is there a possibility to uninstal, install 3.2.1 and just to add the whole list of *.torrent files into 3.2.1 and will it continue to download/upload? Or maybe it 3.3.0 has some new way of downloading and presenting *.torrent files in download directory? They are mostly from private trackers.
Last edited by neXus on Fri Aug 21, 2015 1:56 pm, edited 1 time in total.

neXus
Member
Member
Posts: 22
Joined: Thu May 21, 2015 2:48 pm

Re: Qbittorrent 3.2.3 and audio lag

Post by neXus » Fri Aug 21, 2015 8:43 am

This is first thing I noticed with 3.2.1 and W10. Althought Firefox has association with magnet and torrent files towards Qbit, Qbit just won't pick up and start downloading. Only way to start torrent is to save it on computer, and the in Qbit -> File -> Add Torrent File, or for magnet Add Torrent Link.
Even Win has association with torrent file towards Qbit.

Edit:

I've putted firefox.exe and qbittorrent.exe to start as admin (right click file -> properties -> compatibility -> run as administrator) and now it works.
Last edited by neXus on Fri Aug 21, 2015 8:48 am, edited 1 time in total.

User avatar
ciaobaby
Forum addict
Forum addict
Posts: 2771
Joined: Sat May 18, 2013 4:08 pm

Re: Qbittorrent 3.2.3 and audio lag

Post by ciaobaby » Fri Aug 21, 2015 1:57 pm

So: ... ... 


Is it a 'lag' or a 'stutter'? Because to me those are two different problems.

A 'lag' would be a noticeable time delay between screen actions and the corresponding audio output.

A 'stutter' would be interference of the audio resulting in a  staccato output or 'chopping' of the audio signal.
Smarter than the av-er-age bear, Boo Boo.

http://qbforums.shiki.hu/index.php/topic,3084.0.html

apoklyps3
Member
Member
Posts: 52
Joined: Sat May 30, 2015 2:14 pm

Re: Qbittorrent 3.2.3 and audio lag

Post by apoklyps3 » Fri Aug 21, 2015 3:28 pm

it's definitly stutter, nexus agreed on an earlier post that we are talking about the same thing.
on another matter I installed latest beta and problem still ocurs.

User avatar
Nemo
Administrator
Administrator
Posts: 1579
Joined: Sat Jul 24, 2010 6:24 pm

Re: Qbittorrent 3.2.3 and audio lag

Post by Nemo » Fri Aug 21, 2015 6:55 pm

Seltap's post is also very interesting over here: https://qbforums.shiki.hu/index.php/topic,3743.msg18878.html#msg18878
it is not only happening in combination with qBittorrent, but also in combination with tasks where packets are being sent in rapid manner that is why I am thinking that it is not completely qBittorrent at fault here.
See this Github issue also: https://github.com/qbittorrent/qBittorrent/issues/3664

Especially the last post from Chocobo1 with a possibly ''fix''. Try it I would say.
Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.


Image
Image

neXus
Member
Member
Posts: 22
Joined: Thu May 21, 2015 2:48 pm

Re: Qbittorrent 3.2.3 and audio lag

Post by neXus » Fri Aug 21, 2015 7:10 pm

Call it an audio drop. Lag is where audio or video doesn't follow each other, or goes slower. Stutter whould mean...well, like verbal stutter. Like someone is trying to say R, but in a row R R R R R.
So it's an audio drop. Let's say we have this sentence. Audio drop would sound like "Let's us say (drop(no sound)) sentence".

neXus
Member
Member
Posts: 22
Joined: Thu May 21, 2015 2:48 pm

Re: Qbittorrent 3.2.3 and audio lag

Post by neXus » Sun Aug 23, 2015 4:26 pm

I have returned to W7. W10 is total crap. Even games freeze (only can go to desktop if task manager is called upon), there is a yellow triangle in system tray and that triangle points to file taskhostw.exe (precisely like that).

W10 has a lot of bugs. Rushed out to market and yes...that spying.

User avatar
Nemo
Administrator
Administrator
Posts: 1579
Joined: Sat Jul 24, 2010 6:24 pm

Re: Qbittorrent 3.2.3 and audio lag

Post by Nemo » Sun Aug 23, 2015 4:28 pm

It did got fixed right, now you went back to W7?
Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.


Image
Image

Post Reply