Page 2 of 3

Re: new torrents keep stalling

Posted: Sat Jan 11, 2020 6:23 pm
by Dome
I can't download any torrents because they are stalling. I tried everything to fix it, but I started to gave up... :( With the 4.2.0 update it was good, but since I installed the 4.2.1 update I haven't seen any downloaded torrents. PLEASE try to fix it somehow.

Version 4.2.1
Windows 10

Re: new torrents keep stalling

Posted: Mon Jan 13, 2020 8:02 pm
by slocbit
I see the same issue in the new 4.2.1 (also on Windows 10) - all torrents remain on stalled. The DHT nodes stays at 0.

I run as a standard user account - so I tried running qBittorrent as an admin user and then it works. When running as an admin DHT is > 0, and I can download files correctly.

Previous versions of qBittorrent were working fine when running as a standard user, but the new one doesn't seem to work like this anymore...

Any ideas - would prefer not to have to run it as an admin?

Re: new torrents keep stalling

Posted: Mon Jan 13, 2020 8:40 pm
by Pilzy
Just started tonight, add a torrent and STALLED!

Nothing seems to help and it`s getting bloody irritating!!

Win10 64bit.

Re: new torrents keep stalling

Posted: Tue Jan 14, 2020 9:42 am
by Robolov
Hi Pilzy, please remain courteous. ;)
Did you try what worked for the other people in this thread (launching as admin, checkin your antivirus, etc.)?

Re: new torrents keep stalling

Posted: Sat Jan 25, 2020 7:44 am
by slocbit
Managed to get mine working again by changing the incoming connection port to 49152 - it was on 4500. Not sure exactly why that would make a difference but it's working when I run it as a standard user again now. The admin profile had different settings so when I ran as admin the port was also a different number which is why it was working like that as well - so it's not specifically running as admin that was causing it to work - just the different port number I think.

Re: new torrents keep stalling

Posted: Tue Feb 04, 2020 2:05 pm
by chocopoco
Hi,
Mine is working again by changing the incoming connection port too. I clicked the button to randomize it and the files started to download immediately as soon as the port changed.

Re: new torrents keep stalling

Posted: Tue Feb 04, 2020 5:13 pm
by Splat
Still getting this. My port is set, Upnp port selecting is disabled. My settings are pretty much what they've always been and worked until a few updates ago. Now I go to d/l a torrent and it just sits at stalled, yet there are confirmed seeds.

Re: new torrents keep stalling

Posted: Wed Feb 05, 2020 6:13 pm
by Saitzev
Omg, just registered to thank those that mentioned changing the port. Not sure what happened as I've not made any changes but since Sunday no torrents would download. I figured it was just the torrents, but nope, looks like the port was stealth changed.

I changed it over to 49152 and poof, instead of just hanging on Downloading Metadata, it jumped to Stalled and then immediately it switched to downloading.

Re: new torrents keep stalling

Posted: Thu Feb 06, 2020 6:22 pm
by Splat
I wish my qB stalling issue was that easy to remedy. A lot of times now I need to force reannounce to kick qB into d/l, otherwise it just stays at stalled. It just did it yet again.....like a lot of, if not most, times. There's got to be a reason. I think I'll revert back to v3.3.16 and see what happens.

Re: new torrents keep stalling

Posted: Sat Feb 08, 2020 5:31 am
by SonofThor
There is a definite way to fix the problem. Use a another client. This is madness. Either they can't fix it or won't.....

Either way. You can end the frustration. Move on.........

Re: new torrents keep stalling

Posted: Sat Feb 08, 2020 7:34 pm
by Peter
Or you fix your own network / setup... just maybe.. instead of blaming a client.
I mean, you can use whatever, I couldn't care less. But still, don't blame the computer / client...

Re: new torrents keep stalling

Posted: Sat Feb 08, 2020 7:39 pm
by Splat
Peter wrote:
Sat Feb 08, 2020 7:34 pm
Or you fix your own network / setup... just maybe.. instead of blaming a client.
I mean, you can use whatever, I couldn't care less. But still, don't blame the computer / client...
For those that may not know how to do that, yes. Networking is my job. That's all been checked out. As I noted, this is a recent thing, but I can't put my finger on exactly what version it started. It happened randomly enough back then but has gotten worse. I've reverted back to v3.3.16 and interestingly enough, no stalling yet. Long time user of qB and I appreciate the work that has gone, and goes, into it.

Re: new torrents keep stalling

Posted: Sat Feb 08, 2020 7:44 pm
by Peter
Splat wrote:
Sat Feb 08, 2020 7:39 pm
...
Didn't mean to come off rude but I really don't know what to say or tell people. All I've got is a huge fat of "WorksForMe". Like... I am all for helping people - I always do that. But qBittorrent works. The latest version? Works. I run it on x86, x64, arm64. It works. I run it on big servers. kvm vms. containers. vps. vmware/virtualbox guest. hyper-v guest. on native Windows. Server 2019, 2016. Windows 10, 8.1. Ubuntu, Debian. mobile network? it works. fiber? cable? works. hotspot? wifi? works superb.

Not saying there is no setup where you might encounter problems. No config is the same. But that's my point. It must be something on the client side and not in the client...

Re: new torrents keep stalling

Posted: Sat Feb 08, 2020 7:49 pm
by Splat
Thanks Pete. I know how it goes. I don't like to ever say that it's definitely this-or-that because there's so many possible variables. I've noticed this for about...IIRC maybe two or three months ago and I've been checking everything since then. Nothing on my end, routers, switch, etc. has changed parameters. Maybe it's just a coincidence that the older version hasn't choked yet. I will definitely let you guys know if I find something definitive to help everyone out.

Re: new torrents keep stalling

Posted: Sat Feb 08, 2020 7:54 pm
by Peter
I mean...
- what antivirus/security product do you use?
- do you have an open port forward to your PC? and do you use a static IP on your machine? (thus port forward sticks)
- do you have the Windows firewall disabled?