Bug in qB's latest version (4.2)

Windows specific questions, problems.

Moderators: Global Moderator, Moderator

Post Reply
Twilight666
Newbie
Newbie
Posts: 2
Joined: Fri Dec 06, 2019 10:16 am

Bug in qB's latest version (4.2)

Post by Twilight666 » Fri Dec 06, 2019 10:44 am

I am a user of qB on Windows 10 Home and I have just updated to the latest version (4.2).

When qB opens any incomplete torrents I have are marked with a red ! (exclamation point) saying that the files are missing. I tried various ways to fix it and the one I found works is to press to start the torrent (at which point it starts at 0%) and then press to recheck the files. At that point the check runs successfully and the files reach the right percent they had before the whole mess happened.
But if I close qB before the torrents finish downloading (either manually or as part of closing my PC) the above happens again.

I am not sure why the above happens but I think I have an idea. In my options I have set that incomplete torrents are put in a different folder than the one they are moved on completion. (Also I have chosen the option to have incomplete torrents with the !qB extension but deactivating it changed nothing)

I deactivated the above option, closed qB and moved the files and when qB opened again the torrent files where 'found' correctly.

I have since moved back to the last version (4.1.9.1) and it is working properly, so it is definately an issue with the latest version

saba40
Newbie
Newbie
Posts: 2
Joined: Fri Dec 06, 2019 1:14 pm

Re: Bug in qB's latest version (4.2)

Post by saba40 » Fri Dec 06, 2019 1:20 pm

this is exactly what happens to me

baroni
Newbie
Newbie
Posts: 1
Joined: Fri Dec 06, 2019 7:00 pm

Re: Bug in qB's latest version (4.2)

Post by baroni » Fri Dec 06, 2019 7:19 pm

The bug happens from version 4.2,
If the bug can be fixed then thank you for that.
the image is Hebrew language (qBittorrent 4.2).

Image

HellJake
Newbie
Newbie
Posts: 1
Joined: Sat Dec 07, 2019 10:42 am

Re: Bug in qB's latest version (4.2)

Post by HellJake » Sat Dec 07, 2019 10:48 am

I can confirm. On every start incomplete torrents are marked with a warning. When I force to download it starts at 0%

Thanks to you I now know how to recheck!

saba40
Newbie
Newbie
Posts: 2
Joined: Fri Dec 06, 2019 1:14 pm

Re: Bug in qB's latest version (4.2)

Post by saba40 » Sat Dec 07, 2019 11:28 am

totally the same with me

lobotomizado
Newbie
Newbie
Posts: 1
Joined: Mon Dec 09, 2019 9:42 am

Re: Bug in qB's latest version (4.2)

Post by lobotomizado » Mon Dec 09, 2019 9:46 am

Same here. To close the program is to say goodbye to the progress of those files not finished yet :'(

sbernesto
Newbie
Newbie
Posts: 1
Joined: Wed Dec 11, 2019 1:55 am

Re: Bug in qB's latest version (4.2)

Post by sbernesto » Wed Dec 11, 2019 1:57 am

Hi,

I have the same problem every time I start the application. The previous version did not generate this error.

Splat
Veteran
Veteran
Posts: 78
Joined: Wed Sep 28, 2011 1:36 am

Re: Bug in qB's latest version (4.2)

Post by Splat » Thu Dec 12, 2019 5:31 pm

FWIW, it's not happening to me and hasn't happened since upgrading to latest version.

Twilight666
Newbie
Newbie
Posts: 2
Joined: Fri Dec 06, 2019 10:16 am

Re: Bug in qB's latest version (4.2)

Post by Twilight666 » Fri Dec 13, 2019 5:47 pm

I am sorry, I am the OPand I am new to this forum, and didn't notice the sticky viewtopic.php?f=14&t=3505

Apparently we shouldn't open new topics about bugs here, but go directly to github and open an issue there

This bug has been known for a while (https://github.com/qbittorrent/qBittorrent/issues/11552), so people should go there instead, and this thread should be locked instead.

Also it looks like there might have found a fix for it ^-^

Post Reply