Help Req: QBT killing my USB transfer speeds

Windows specific questions, problems.
Post Reply
tktorrents
Newbie
Newbie
Posts: 1
Joined: Thu Oct 15, 2020 4:50 am

Help Req: QBT killing my USB transfer speeds

Post by tktorrents »

Hopefully someone has seen this before and knows the answer.

I'm running a laptop with an Intel i7-7820HK, nVidia GTX 1080, 32GB RAM, 1TB SSD, Win 10 Pro and qBittorrent v4.2.5. As you can see the laptop is no slouch by any means.

At some point (I have no exact idea when) over the last few months I started having troubles copying files/data from my internal SSD to an external mechanical hard drive via USB 3.0/3.1. My transfers would at best max out around 15MB/s, but are mostly stuck around the 1MB/s to 5MB/s ranges with it frequently dropping to KB/s levels and even pausing at 0KB/s where before they would hit 60MB/s and stay at 60MB/s the entire transfer.

Just today I finally discovered that if I shut down qBittorrent, my speeds suddenly reach for the sky and are stable again. Keep in mind that this happens WITHOUT transfers running so it's not like my SSD is maxed out on read/writes already.

This speed drop ONLY happens IF I'm running qBittorrent before starting my transfer. If I close qBittorent, then start my transfer, then re-load qBittorrent... then my transfer speeds stay stable. It's as if qBittorrent is taking crazy priority over anything that runs after it's' loaded, but can't force take that priority from something already running. (hope that makes sense).

Before discovering this I tried all the usual things from different USB cables, hard drives and then tested all those components on different PCs (which they all ran fantastically until I tried them on the laptop again).


What's going on here and is there a setting or something I need to change? This issue only started in the last few months and uninstalling/reintalling QBT hasn't helped. Not sure if it's a bug with a recent version or what, but I'm at a loss for what's causing this.

I really appreciate any ideas with this,
thank you.
Post Reply