Page 1 of 1

Hangs on "retrieving metadata" screen

Posted: Thu Nov 12, 2020 5:16 am
by jmb
Running 64bit. This used to work just fine and now it hangs on retrieving metadata. It worked for a few torrents last week and now it is not working again. This is frustrating!

Running through Nord VPN.

Re: Hangs on "retrieving metadata" screen

Posted: Sun Nov 15, 2020 1:05 am
by joshhazel
This is more of a personal observation than something that will help you much. If you are referring to it being stuck at "Downloading Metadata" . I am having the same problem using NordVPN SOCKS5. But I also tested with TorGuard SOCKS5, having similar issues. I also tried some of these failing ones using a seedbox, and they are also having the problem. If you have all your other settings like port forwarding setup correctly, then it might just be crap torrents. I noticed these torrents, most of the trackers say "NOT WORKING"

Try a test download of ubuntu, if this torrent works then your client is probably not the problem ... ittorrents

Re: Hangs on "retrieving metadata" screen

Posted: Mon Nov 16, 2020 12:01 am
by Peter
Yeah it simply means you are passive. Most VPNs don't have port forwarding (including NordVPN). And SOCKS5 will also render you passive. These all will cause this. Mullvad/Windscribe does have port forwarding if you MUST use a VPN. ps.: no we don't endorse them, I use them, they work, etc.

Re: Hangs on "retrieving metadata" screen

Posted: Fri Nov 20, 2020 10:42 am
by ericiscool
I'm having the same issue on latest version v.

This doesn't happen for every magnet link, but quite a few.

What I have already tried that was suggested in my searches:

1.) Toggling file associate box on options>behavior

2.) checking registry (\Magnet\shell\open\command) (seems to already be fixed in latest versions)

3.) disabling anonymous mode

4.) deleting all app data settings

5.) force closing and restarting the program.

6.) enabling port forwarding in my vpn settings (pia) and choosing a compatible vpn server (although this still happens when I'm not using a vpn)

Nothing works.

Is there anything else that is causing this or a way to fix it?

Re: Hangs on "retrieving metadata" screen

Posted: Mon Nov 23, 2020 6:19 pm
by jmb
Peter - Thanks for the explanation. I use Nord VPN so I switched to "Transmission" and all is well...

BTW, I originally tried to download magnet torrents without being connected to VPN and same issue.