qB 4.3.5 "not responding" when add new torrent from specific tracker

Windows specific questions, problems.
Post Reply
StasBrd
Newbie
Newbie
Posts: 1
Joined: Sat May 29, 2021 3:12 pm

qB 4.3.5 "not responding" when add new torrent from specific tracker

Post by StasBrd »

Hello! About a week ago, I started having problems adding new torrents from one specific tracker: when adding a new download, the client immediately freezes. Based on the information from the Task Manager and Process Monitor, it continues to work for some time (while remaining in the not "responding" status), after which it stops and is gradually unloaded from memory to 0-1 MB and still not responding.

About half of the torrents from the tracker that hangs the client open normally.

When the problem started, there were just over 2k torrents in the client, of which 740 were from the problem tracker. After removing 200 downloads from this tracker, new torrents that had previously froze the client began to be added normally, but after a while (when about 50 downloads were added from this tracker), the client began to freeze again.

I couldn't establish a pattern that allows predicting why some torrents add normally, and some do not.

I wrote about the problem on the tracker forum - all torrents are working. Also advised:

1) Remove in the tracker settings adding retracker to the torrent file

2) Remove the search for local peers in the client settings (it was already disabled)

3) Remove retracker in already running torrents

4) Do not add the torrent name to the name of the torrent file.

Nothing helped.

I've tested another 20 trackers (2 torrents from each) and 10 torrents from another tracker - everything starts without problems.

After a clean reinstallation (deleted settings, distributions, registry entries), all torrents from the problem tracker are added normally, without freezing the client.

OS: Windows 10 21H1 19043.1023
Client: qBittorrent 4.3.5

No VPN. PC connected to wi-fi router trough ethernet, portforwarded through a specific port in router settings, port is opened (2ip.ru port check), sticky dynamic IP-address if i correct (i've got personal external IP, which sometime changes after reconnection) though connection never been a problem.

Execution log always contains successful connection:

Code: Select all

31.05.2021 14:24 - UPnP/NAT-PMP: Port mapping successful, message: successfully mapped port using UPnP. external port: UDP/
31.05.2021 14:24 - UPnP/NAT-PMP: Port mapping successful, message: successfully mapped port using UPnP. external port: TCP/
31.05.2021 14:24 - Detected external IP: 
31.05.2021 14:24 - Successfully listening on IP: ::1, port: UDP/
etc
The downloaded files are located on three external HDDs:
2 x WD 10TB Elements - USB 3.0 and USB 2.0
Seagate Expansion Desktop 8TB - USB 2.0

The system was checked by the programs Cure It!, Kaspersky Free Virus Removal Tool, Malwarebytes. Kaspersky Security Cloud is also constantly running - nothing serious found.

I updated the client on May 9, the problem appeared on May 24, so it doesn't seem to be a client bug.

Screenshots of client settings in attached archive.
Attachments
Client settings.zip
My qBittorrent settings
(100 KiB) Downloaded 8 times
User avatar
Peter
Administrator
Administrator
Posts: 2009
Joined: Wed Jul 07, 2010 6:14 pm

Re: qB 4.3.5 "not responding" when add new torrent from specific tracker

Post by Peter »

Hi there! Thank you for the detailed report.

Did you report the issue over the Github tracker?
https://github.com/qbittorrent/qBittorrent/issues/

Please, also include the tracker's name next time. (So they could contact us, we could reach out, etc.)
Post Reply