qBittorrent 3.3.16 on Linux Mint

Linux specific questions, problems.
Post Reply
User avatar
fixxOrz
Newbie
Newbie
Posts: 3
Joined: Sun May 31, 2020 4:49 pm

qBittorrent 3.3.16 on Linux Mint

Post by fixxOrz » Tue Jun 09, 2020 2:13 pm

A private tracker I use strongly recommends using qBittorrent 3.3.16, because "all qBittorrent 4.x.x versions have seen connection issues and other bugs." So I've installed qbt 3.3.16, but it won't run. Here's what happens when trying to launch from the terminal:

Code: Select all

$ qbittorrent
qt5ct: using qt5ct plugin 
qbittorrent: symbol lookup error: qbittorrent: undefined symbol: _ZN10libtorrent20generate_fingerprintESsiiii
I don't know how to interpret this or have any idea how to fix it. From what I could find, it looks like a conflict with libtorrent, but I don't know what to do with that information. Any help would be greatly appreciated.

Code: Select all

if ( hasFever() ) {
return ((Cowbell) Prescription.getInstance ())++;
}

User avatar
fixxOrz
Newbie
Newbie
Posts: 3
Joined: Sun May 31, 2020 4:49 pm

Re: qBittorrent 3.3.16 on Linux Mint

Post by fixxOrz » Mon Jun 15, 2020 2:30 pm

For anyone else who might have this problem, I solved it by following the compilation guide for debian and ubuntu available from the qbittorrent github page: https://github.com/qbittorrent/qBittorr ... and-Ubuntu. I tried compiling again based on this guide, and it worked perfectly! It turns out I was still missing some build tools, but the big step I missed before was compiling the libtorrent v1.1.x that qbittorent v3.3.16 needs (I only had libtorrent v1.2.x installed before).

Code: Select all

if ( hasFever() ) {
return ((Cowbell) Prescription.getInstance ())++;
}

Post Reply