Linux all stalled, same torrents on Windows all fine

Linux specific questions, problems.
Post Reply
ranec
Newbie
Newbie
Posts: 2
Joined: Mon Mar 01, 2021 5:01 pm

Linux all stalled, same torrents on Windows all fine

Post by ranec »

So I have this issue with qbittorrent on my Raspberry PI.
On my Windows 10 machine on the same LAN all the links I've tried work great.
On my R-Pi lots of the links all stay stalled forever.
I've checked all the encryption, BT settings & they all look the same.
Any way I can debug the sessions etc to find out why they work just fine on the Win machine but not the Raspbian machine?
ranec
Newbie
Newbie
Posts: 2
Joined: Mon Mar 01, 2021 5:01 pm

Re: Linux all stalled, same torrents on Windows all fine

Post by ranec »

What's weird is I start the downloads, see 100's of peers & seeds and one by one each d/l loses all of them & goes to zero of each.
User avatar
Peter
Administrator
Administrator
Posts: 1996
Joined: Wed Jul 07, 2010 6:14 pm

Re: Linux all stalled, same torrents on Windows all fine

Post by Peter »

What about permissions? Where are you trying to download to? Are permissions OK on the target folder? (Ownership, chmod, etc)
kaveman
Newbie
Newbie
Posts: 4
Joined: Mon Mar 29, 2021 11:51 pm

Re: Linux all stalled, same torrents on Windows all fine

Post by kaveman »

ranec wrote: Mon Mar 01, 2021 5:06 pm So I have this issue with qbittorrent on my Raspberry PI.
On my Windows 10 machine on the same LAN all the links I've tried work great.
On my R-Pi lots of the links all stay stalled forever.
I've checked all the encryption, BT settings & they all look the same.
Any way I can debug the sessions etc to find out why they work just fine on the Win machine but not the Raspbian machine?
when I saw this post I created an account just to jump in and mention I'm having the precise same issue as you, I setup a media server on ubuntu 20 this past weekend using docker, everything was working fine for a while but I noticed last night that I had torrents just sort of stalling out without saying they were stalling, I realized all connections were 0 kb/s and nothing was happening, I had noticed something similar to this on the weekend so i tried restarting qbittorrent and then restarting the container it was in, both no luck. I thought maybe somehow permissions got screwed up for the downloads folder but that was fine. I also was able to confirm the torrents were fine, they were originally downloading fine and they work fine in windows. The issue is specific to the linux version it seems and I have no idea whats causing it since im running qbittorrent in a container alone and it was running fine for days
unseen19
Member
Member
Posts: 41
Joined: Mon Mar 15, 2021 1:36 pm

Re: Linux all stalled, same torrents on Windows all fine

Post by unseen19 »

libtorrent version are the same on both Win/Linux?
kaveman
Newbie
Newbie
Posts: 4
Joined: Mon Mar 29, 2021 11:51 pm

Re: Linux all stalled, same torrents on Windows all fine

Post by kaveman »

ranec wrote: Mon Mar 01, 2021 5:06 pm So I have this issue with qbittorrent on my Raspberry PI.
On my Windows 10 machine on the same LAN all the links I've tried work great.
On my R-Pi lots of the links all stay stalled forever.
I've checked all the encryption, BT settings & they all look the same.
Any way I can debug the sessions etc to find out why they work just fine on the Win machine but not the Raspbian machine?
I just resolved this recently by disabling Upnp after port forwarding 6881, when I found Upnp to not be working exactly right with qbittorrent in a docker container I ended up port forwarding. I forgot to disable Upnp and with both setup all my torrents were able to connect to seeders and leechers but could not move any data. As soon as I turned off Upnp on qbittorrent the port forwarding worked properly and data started moving instantly
sutten
Newbie
Newbie
Posts: 8
Joined: Wed Nov 13, 2019 12:50 pm

Re: Linux all stalled, same torrents on Windows all fine

Post by sutten »

Hey, I agree, that's really weird, never happened to me.
Post Reply