"Cannot make save path" and no rights to USB mounted drive (SOLVED)

Linux specific questions, problems.
Post Reply
echdareez
Newbie
Newbie
Posts: 1
Joined: Wed Mar 17, 2021 6:11 pm

"Cannot make save path" and no rights to USB mounted drive (SOLVED)

Post by echdareez »

Hi there,

I wanted to create a Raspbian based torrent-box (more out of curiosity) and grabbed a Pi3 and went ahead with the install/config. But alas : I got everything working except for the download dir ("Cannot make save path" appears if I do the "Set Location..." on a test-torrent).

What I've done :
- create a system user called qbittorrent
- gparted a NVME drive with one single partition (ext4)
- mounted my drive as follows / edited the fstab file with this line :
UUID=78cd0e91-8748-4000-add0-d84340e169e1 /media/NVME-500GB ext4 default,auto,users,rw,nofail 0 0
- chmod'd the directory with full rights for anything :
[email protected]:/media $ ls -l
total 8
drwxrwxrwx 5 qbittorrent root 4096 Mar 17 19:04 NVME-500GB

I've done some testing and it seems I can create folders and files inside that "NVME-500GB" so I'm stuck on what might be the problem. Any pointers would be appreciated :-)

thanks!
/d

UPDATE : Fixed it as follows :
1. created a dir under /home/qbittorrent/NVME
2. set the rights again on that folder
3. modified the fstab to point to that dir
4. rebooted and it worked :-)
Post Reply