[official]qBittorrent 3.3.16 installer - Built with MSVC 2017

Testing the freshly baked, latest builds!

Moderator: Global Moderator

sledgehammer_999
Administrator
Administrator
Posts: 2411
Joined: Sun Jan 23, 2011 1:17 pm

Re: [official]qBittorrent 3.3.0 installer - Built with MSVC 2013

Post by sledgehammer_999 » Mon Dec 07, 2015 11:40 pm

Here is qBittorrent 3.3.1 built with MSVC 2013 express.

3.3.1 link-> http://www.fosshub.com/qBittorrent.html
Changelog: http://www.qbittorrent.org/news.php

Libraries's version used:
Libtorrent: 1.0.7 (final)
Qt: 5.5.1
Boost: 1.59.0

fusk
Veteran
Veteran
Posts: 250
Joined: Sun Feb 23, 2014 1:39 am

Re: [official]qBittorrent 3.3.1 installer - Built with MSVC 2013

Post by fusk » Mon Dec 07, 2015 11:48 pm

Thanks.
Bug with temp drives is still present. If temp is enabled, on reboot qbit will copy as many torrents as possible back onto temp drive. However, it's a copy.

sledgehammer_999
Administrator
Administrator
Posts: 2411
Joined: Sun Jan 23, 2011 1:17 pm

Re: [official]qBittorrent 3.3.1 installer - Built with MSVC 2013

Post by sledgehammer_999 » Mon Dec 07, 2015 11:50 pm

Bug with temp drives is still present. If temp is enabled, on reboot qbit will copy as many torrents as possible back onto temp drive. However, it's a copy.
What is the bug? Steps to reproduce. (be sure that the paths are correct in settings, because v3.3.0 borked some of them)

fusk
Veteran
Veteran
Posts: 250
Joined: Sun Feb 23, 2014 1:39 am

Re: [official]qBittorrent 3.3.1 installer - Built with MSVC 2013

Post by fusk » Mon Dec 07, 2015 11:55 pm

Steps to reproduce. Enable a temp dir, reboot.
Path g:\ is correct, i disabled it in 3.3.0 because it didn't work, on every reboot it would copy everything back onto temp. 3.1 does the same.
In some cases it also changes the download destination to g: even tho it was never g: in the first place. Changing it back to the original path does nothing.
Last edited by fusk on Mon Dec 07, 2015 11:59 pm, edited 1 time in total.

fastxaxe
Newbie
Newbie
Posts: 1
Joined: Mon Jun 15, 2015 6:44 am

Re: [official]qBittorrent 3.3.1 installer - Built with MSVC 2013

Post by fastxaxe » Tue Dec 08, 2015 1:17 am

Hi,

I'll second 'fusk's comment.

Exactly the same problem (and versions)

Ryrynz
Member
Member
Posts: 51
Joined: Wed Sep 04, 2013 1:52 pm

Re: [official]qBittorrent 3.3.1 installer - Built with MSVC 2013

Post by Ryrynz » Tue Dec 08, 2015 5:50 am

Is the updated theme coming in a later 3.3.x release or now 3.4?

schnurlos
Newbie
Newbie
Posts: 10
Joined: Sun Mar 08, 2015 9:17 pm

Re: [official]qBittorrent 3.3.1 installer - Built with MSVC 2013

Post by schnurlos » Tue Dec 08, 2015 10:08 am

@sledge: in build 3.3.1 seems to be an untranslateable text (Settings, advanced):

Image.

Also the "Resolve peer host names" seems not to work when checked in that build.
But congrats for all the work!
Never stop waiting for something better.

User avatar
Nemo
Administrator
Administrator
Posts: 1541
Joined: Sat Jul 24, 2010 6:24 pm

Re: [official]qBittorrent 3.3.1 installer - Built with MSVC 2013

Post by Nemo » Tue Dec 08, 2015 12:28 pm

Great update, will install when im at home.
Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.


Image
Image

sledgehammer_999
Administrator
Administrator
Posts: 2411
Joined: Sun Jan 23, 2011 1:17 pm

Re: [official]qBittorrent 3.3.1 installer - Built with MSVC 2013

Post by sledgehammer_999 » Tue Dec 08, 2015 10:29 pm

[quote="Ryrynz"]
Is the updated theme coming in a later 3.3.x release or now 3.4?
[/quote]

Don't know.

sledgehammer_999
Administrator
Administrator
Posts: 2411
Joined: Sun Jan 23, 2011 1:17 pm

Re: [official]qBittorrent 3.3.1 installer - Built with MSVC 2013

Post by sledgehammer_999 » Tue Dec 08, 2015 10:30 pm

[quote="schnurlos"]
@sledge: in build 3.3.1 seems to be an untranslateable text (Settings, advanced):

Image.

Also the "Resolve peer host names" seems not to work when checked in that build.
But congrats for all the work!
[/quote]

The string was changed slightly in v3.3.1 that's why it is untranslated. Due to the urgenct of the fixes I didn't give time to translators.

sledgehammer_999
Administrator
Administrator
Posts: 2411
Joined: Sun Jan 23, 2011 1:17 pm

Re: [official]qBittorrent 3.3.1 installer - Built with MSVC 2013

Post by sledgehammer_999 » Tue Dec 08, 2015 10:38 pm

[quote="fusk"]
Steps to reproduce. Enable a temp dir, reboot.
Path g:\ is correct, i disabled it in 3.3.0 because it didn't work, on every reboot it would copy everything back onto temp. 3.1 does the same.
In some cases it also changes the download destination to g: even tho it was never g: in the first place. Changing it back to the original path does nothing.
[/quote]

Can you be more specific and give step-by-step instructions? Is reboot necessary or restarting qbt is the same? At what point you add a torrent and at what point you disable the temp? That's why I need step-by-step instructions.

fusk
Veteran
Veteran
Posts: 250
Joined: Sun Feb 23, 2014 1:39 am

Re: [official]qBittorrent 3.3.1 installer - Built with MSVC 2013

Post by fusk » Wed Dec 09, 2015 7:42 pm

[quote="sledgehammer_999"]
Can you be more specific and give step-by-step instructions? Is reboot necessary or restarting qbt is the same? At what point you add a torrent and at what point you disable the temp? That's why I need step-by-step instructions.
[/quote]
Well, enabling temp dir and reboot is basically all there is to it. Ok, so i got 10 torrents in qbit, temp disabled. I update to the latest version, hoping the bug that was introduced in 3.3.0 was fixed. So i enable temp dir, everything seems fine.
I have qbit starting auto with windows. win10 x64.

But, then you reboot, restarting qbit does nothin, you need to reboot. When qbit starts for some reason it starts copying everything onto temp, or until temp is full. I doesn't move the files, just makes a copy. After that you disable temp, because who needs this feature?. The save location stays the same on the torrents, but in some cases it does change it to temp:\. Logs shows nothing.
That's why i made the step by step, two steps.



Hope that about covers it.
Last edited by fusk on Wed Dec 09, 2015 8:13 pm, edited 1 time in total.

sledgehammer_999
Administrator
Administrator
Posts: 2411
Joined: Sun Jan 23, 2011 1:17 pm

Re: [official]qBittorrent 3.3.1 installer - Built with MSVC 2013

Post by sledgehammer_999 » Wed Dec 09, 2015 9:44 pm

When qbit starts for some reason it starts copying everything onto temp, or until temp is full.
Can you check what the log says at that point? I am pretty sure it says something about rejected/corrupted fastresumes. (copy the error here)

fusk
Veteran
Veteran
Posts: 250
Joined: Sun Feb 23, 2014 1:39 am

Re: [official]qBittorrent 3.3.1 installer - Built with MSVC 2013

Post by fusk » Wed Dec 09, 2015 10:48 pm

sledgehammer_999 wrote:
When qbit starts for some reason it starts copying everything onto temp, or until temp is full.
Can you check what the log says at that point? I am pretty sure it says something about rejected/corrupted fastresumes. (copy the error here)
It does not. It looks completely normal. No errors. It would say "resumed. (fast resume)" like it always do. However, i do have 2 errors from today, but i do not know what those are from as all resumed fine.
But i deleted a large amount yesterday. It doesn't mentioned which they are, only that they failed to resume and then their checksum. I disabled temp before that, so that should be unrelated.

I don't actually think qbit resumes from the copies. I think it resumes from the originals. Might be why there's no errors.
Last edited by fusk on Thu Dec 10, 2015 11:11 am, edited 1 time in total.

Ryrynz
Member
Member
Posts: 51
Joined: Wed Sep 04, 2013 1:52 pm

Re: [official]qBittorrent 3.3.1 installer - Built with MSVC 2013

Post by Ryrynz » Mon Feb 01, 2016 9:13 am

[quote="Ryrynz"]
Is the updated theme coming in a later 3.3.x release or now 3.4?
[/quote]

I'm guessing 3.4..

Post Reply