[official]qBittorrent 3.0.11 installer - Built with MSVC 2008 and uTP support

Testing the freshly baked, latest builds!

Moderator: Global Moderator

sledgehammer_999
Administrator
Administrator
Posts: 2410
Joined: Sun Jan 23, 2011 1:17 pm

Re: qbt 2.8.5 **msvc2008 build**

Post by sledgehammer_999 » Tue Sep 27, 2011 9:35 pm

[quote="Rastaman"]
Adding a list of changes/fixes per release would be nice :P
[/quote]

Just wait for an "official" release. It will have the changes listed here->http://qbittorrent.sourceforge.net/news.php
I won't publish any changes for builds from git master. A rough changelog would be the git log, found here->https://gitorious.org/qbittorrent/qbitt ... its/master

User avatar
s4nder
Member
Member
Posts: 57
Joined: Fri Jun 10, 2011 8:15 pm

Re: qbt 2.8.5 **msvc2008 build**

Post by s4nder » Thu Sep 29, 2011 3:24 pm

sledge, are you going to compile other RC builds of 2.9.0 for Windows as well? I see RC2 is available now.

I'm also getting another I/O error with RC1 "The parameter is incorrect."
Last edited by s4nder on Thu Sep 29, 2011 4:32 pm, edited 1 time in total.

User avatar
Nemo
Administrator
Administrator
Posts: 1520
Joined: Sat Jul 24, 2010 6:24 pm

Re: qbt 2.8.5 **msvc2008 build**

Post by Nemo » Fri Sep 30, 2011 4:40 pm

Im also gettin random I/O errors with the RC1 but it depends on which torrents I start to download. Most of the time it downloads fine but somehow with few torrents its causes I/O errors like you mention it s4nder. And the torrents are all english, no asian characters or such. It might be fixed with RC2 :o.
Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.


Image
Image

User avatar
s4nder
Member
Member
Posts: 57
Joined: Fri Jun 10, 2011 8:15 pm

Re: qbt 2.8.5 **msvc2008 build**

Post by s4nder » Fri Sep 30, 2011 5:40 pm

In my case the torrent with the I/O error was a huge 18 GB file. Also, three of my completed torrents start off in a paused state every time I launch the program. They seed fine after resuming them. Strange.

sledgehammer_999
Administrator
Administrator
Posts: 2410
Joined: Sun Jan 23, 2011 1:17 pm

Re: qbt 2.8.5 **msvc2008 build**

Post by sledgehammer_999 » Sat Oct 01, 2011 11:19 pm

The 2.9.0 release is near.

As for the random I/O errors, please open a bug report on launchpad, describing the situation-> When do you get it? Totally randomly? etc etc and anything else that may help. Also copy-paste the exact message from the "execution log"(torrent name not necessary). Any discussion on this bug should occur on launchpad where info can be gathered per topic centrally. This isn't a support thread.

User avatar
Nemo
Administrator
Administrator
Posts: 1520
Joined: Sat Jul 24, 2010 6:24 pm

Re: qbt 2.8.5 **msvc2008 build**

Post by Nemo » Sat Oct 08, 2011 9:36 am

Finally there is v2.9.0 with interesting features and fixes, can't wait for your build already sledge :D.
Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.


Image
Image

sledgehammer_999
Administrator
Administrator
Posts: 2410
Joined: Sun Jan 23, 2011 1:17 pm

Re: qbt 2.8.5 **msvc2008 build**

Post by sledgehammer_999 » Sat Oct 08, 2011 9:59 am

I just uploaded it to sf. Give it some time to propagate through the mirrors and it should pop up while running qbt 2.8.5. (or go to the site and download it :P)

sledgehammer_999
Administrator
Administrator
Posts: 2410
Joined: Sun Jan 23, 2011 1:17 pm

Re: qbt 2.8.5 **msvc2008 build**

Post by sledgehammer_999 » Sat Oct 08, 2011 10:00 am

I also enabled openssl in qt so now you can have even more security options in "preferences->Webui"

sledgehammer_999
Administrator
Administrator
Posts: 2410
Joined: Sun Jan 23, 2011 1:17 pm

Re: qbt 2.8.5 **msvc2008 build**

Post by sledgehammer_999 » Sat Oct 08, 2011 10:22 am

I spotted some regressions in my build. I have corrected the code and I am rebuilding now. I deleted the old build from sf, hopefully no one downloaded it.

User avatar
ironcross
Veteran
Veteran
Posts: 433
Joined: Sun Aug 29, 2010 5:34 pm

Re: qbt 2.8.5 **msvc2008 build**

Post by ironcross » Sat Oct 08, 2011 11:07 am

I'm not downloaded it yet and i'm waiting for your proper release :)

sledgehammer_999
Administrator
Administrator
Posts: 2410
Joined: Sun Jan 23, 2011 1:17 pm

Re: qbt 2.8.5 **msvc2008 build**

Post by sledgehammer_999 » Sat Oct 08, 2011 11:16 am

I just uploaded the correct version. It should be ok to download it now.

User avatar
ironcross
Veteran
Veteran
Posts: 433
Joined: Sun Aug 29, 2010 5:34 pm

Re: qbt 2.8.5 **msvc2008 build**

Post by ironcross » Sat Oct 08, 2011 3:10 pm

I just downloaded and installed your latest 2.9.0 release. Currently i have no downloads, only seeds. It started to seed immediately with the maximum speed, but also i received an I/O error saying "The parameter is incorect". I started check on this torrent and received the same error during the check.
I rolled back to 2.8.5. and received the same error  :o I never had problems with 2.8.5. But after restart of the PC 2.8.5 finalized the torrent check and now it's OK, no more I/O errors.
I will stay with 2.8.5.
By the way i noticed that 2.9.0 have smaller installation exe-file - 5.5 MB. The previous versions are about 7 MB.
Last edited by ironcross on Sat Oct 08, 2011 3:13 pm, edited 1 time in total.

sledgehammer_999
Administrator
Administrator
Posts: 2410
Joined: Sun Jan 23, 2011 1:17 pm

Re: qbt 2.8.5 **msvc2008 build**

Post by sledgehammer_999 » Sat Oct 08, 2011 3:19 pm

@ironcross What os do you use? Could you use more the 2.9.0? Does the I/O error appear when downloading a torrent and not seeding it?

The size is smaller because I link every lib statically. If you look at qbt's program files, you'll see only one executable.

User avatar
ironcross
Veteran
Veteran
Posts: 433
Joined: Sun Aug 29, 2010 5:34 pm

Re: qbt 2.8.5 **msvc2008 build**

Post by ironcross » Sat Oct 08, 2011 4:00 pm

The OS is Win 7 Pro SP1 32-bit.
I will try 2.9.0. again...
* * *
Same error at the same torrent again. Restarted the PC - no change. Deleted the torrent file, but no downloaded data, and then downloaded the torrent file again to start checking - same error. Deleted all - the torrent file and the downloaded data, started downloading again - same error at the beginning. Delete all again, started downloading from other tracker - same error again.
Last edited by ironcross on Sat Oct 08, 2011 4:33 pm, edited 1 time in total.

User avatar
Nemo
Administrator
Administrator
Posts: 1520
Joined: Sat Jul 24, 2010 6:24 pm

Re: qbt 2.8.5 **msvc2008 build**

Post by Nemo » Sat Oct 08, 2011 5:35 pm

Thanks sledge, as ironcross mentions it I got the same I/O error reports. Reverting back and rechecking the file fixes the issue but after installing v2.9.0 again the error pops up after few seconds. Imma try few more things, if something changes ill report here ;).
Forum Rules and Guidelines

Forum Admin.
Dutch & Turkish Translator.


Image
Image

Post Reply