Qbittorrent not loading the web ui properly (not showing any torrents)

Linux specific questions, problems.
Post Reply
botnewb
Newbie
Newbie
Posts: 1
Joined: Thu Aug 05, 2021 6:41 pm

Qbittorrent not loading the web ui properly (not showing any torrents)

Post by botnewb »

Hello,

So my qbit (4.3.7) was working for me, up until I had to restart my server. Afterwards, qbittorrent loads, the web ui loads, but I don't see any of my torrents or categories. The torrents are still seeding though, and can still download/upload. So far I have tried:

- setting the disk cache to -1
- restarting the service
- downgrading to a previous version which did load my categories and tags but I don't think thats really the solution
- clearing cache and site data

But none of these has worked. Is there anything I haven't tried, or do I just have to delete the fastresume files? I really don't want to do this because I have 6000+ torrents and 10s of TBs to recheck, so this is really a last resort to do.
unseen19
Veteran
Veteran
Posts: 87
Joined: Mon Mar 15, 2021 1:36 pm

Re: Qbittorrent not loading the web ui properly (not showing any torrents)

Post by unseen19 »

So the Web UI is well loaded with menus, but no torrent shown.Are the filters "all" well selected for all? (status, trackers, etc.).
At least 4 of them should be on "all" to display all If I'm not wrong.

Does the error log shows anything?
spalago
Newbie
Newbie
Posts: 1
Joined: Fri Aug 20, 2021 4:41 pm

Re: Qbittorrent not loading the web ui properly (not showing any torrents)

Post by spalago »

Image
I have the same problem. Almost nothing is working. Buttons except the menu are not responding when they're clicked.
unseen19
Veteran
Veteran
Posts: 87
Joined: Mon Mar 15, 2021 1:36 pm

Re: Qbittorrent not loading the web ui properly (not showing any torrents)

Post by unseen19 »

@spalago
So this is the WebUI pointing to the local host? The full client is installed or do we speak about the NOX version?
What are the content of the logs through SSH?
With a different browser and in private mode? (just to exclude some stuff)

And I guess no local FW or else avoiding any content on the port 8080, and no VPN
SeeGee
Newbie
Newbie
Posts: 1
Joined: Mon Sep 13, 2021 4:29 pm

Re: Qbittorrent not loading the web ui properly (not showing any torrents)

Post by SeeGee »

I am also having the same issue. Cleared browser data and cookies/cache, tried a different browser, all the same result. This seems to have happened with the last update.

Update:
2 weeks later, still having this issue. Any suggestions? The client is still working, sonarr and friends are still able to communicate with the client normally. Only the webui is malfunctioning.
dmeyer0
Newbie
Newbie
Posts: 2
Joined: Sat Oct 16, 2021 12:45 am

Re: Qbittorrent not loading the web ui properly (not showing any torrents)

Post by dmeyer0 »

I'm having the same problem - server is on a mac running the latest OS. Multiple browsers from multiple machines have the same result, including from the mac itself using localhost.

It only seems to happen with more than about 20 torrents - if I remove enough torrents the webui starts working normally again. It might not be the number of torrents, of course - it might just be one bad torrent (or tracker, or peer, or whatever) that's tripping things up. One weird thing: the button to switch to the alternate speed limits works, and does actually effect the server.

BTW, I just checked 4.4.0beta3, and it behaves the same as 4.3.8.

I get no errors on the server (other than ssl errors due to hostname errors and self-signed certs).

Safari console is showing errors:

Code: Select all

[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (WebKitShadower.js, line 0)
http://jhereg:8081/plugins/mochaui/Window/WebKitShadower.js
[Error] Refused to execute http://jhereg:8081/plugins/mochaui/Window/WebKitShadower.js as script because "X-Content-Type-Options: nosniff" was given and its Content-Type is not a script MIME type.
[Error] TypeError: Type error
	(anonymous function) (client.js:100)
	getTrackerHost (client.js:100)
	onSuccess (client.js:627)
	(anonymous function) (MooTools-Core-1.6.0-compat-compressed.js:5:19493)
	forEach
	(anonymous function) (MooTools-Core-1.6.0-compat-compressed.js:5:2717)
	each (MooTools-Core-1.6.0-compat-compressed.js:5:4569)
	fireEvent (MooTools-Core-1.6.0-compat-compressed.js:5:19453)
	(anonymous function) (MooTools-Core-1.6.0-compat-compressed.js:5:18127)
	onSuccess (MooTools-Core-1.6.0-compat-compressed.js:7:23993)
	(anonymous function) (MooTools-Core-1.6.0-compat-compressed.js:5:18127)
	success (MooTools-Core-1.6.0-compat-compressed.js:7:30359)
	(anonymous function) (MooTools-Core-1.6.0-compat-compressed.js:5:18127)
	onStateChange (MooTools-Core-1.6.0-compat-compressed.js:7:23497)
	(anonymous function) (MooTools-Core-1.6.0-compat-compressed.js:5:18127)
	(anonymous function) (MooTools-Core-1.6.0-compat-compressed.js:5:10946)
Chrome's log looks like

Code: Select all

jhereg/:1 Unchecked runtime.lastError: The message port closed before a response was received.
jhereg/:1 Error handling response: TypeError: Cannot read properties of undefined (reading 'msg')
    at chrome-extension://fjccjnfkdkdmjohojoggodkigkjkkjhl/contentscript.js:41:11
MooTools-Core-1.6.0-compat-compressed.js:6 GET http://jhereg:8081/plugins/mochaui/Window/WebKitShadower.js net::ERR_ABORTED 404 (Not Found)
bottom @ MooTools-Core-1.6.0-compat-compressed.js:6
inject @ MooTools-Core-1.6.0-compat-compressed.js:6
javascript @ mocha.min.js:26
getAsset @ mocha.min.js:26
r.extend.$owner @ MooTools-Core-1.6.0-compat-compressed.js:5
(anonymous) @ mocha.min.js:26
(anonymous) @ MooTools-Core-1.6.0-compat-compressed.js:5
(anonymous) @ MooTools-Core-1.6.0-compat-compressed.js:5
each @ MooTools-Core-1.6.0-compat-compressed.js:5
requireContinue @ mocha.min.js:26
r.extend.$owner @ MooTools-Core-1.6.0-compat-compressed.js:5
(anonymous) @ MooTools-Core-1.6.0-compat-compressed.js:5
setTimeout (async)
delay @ MooTools-Core-1.6.0-compat-compressed.js:5
initialize @ mocha.min.js:26
(anonymous) @ MooTools-More-1.6.0-compat-compressed.js:5
r.extend.$owner @ MooTools-Core-1.6.0-compat-compressed.js:5
(anonymous) @ MooTools-Core-1.6.0-compat-compressed.js:5
(anonymous) @ mocha.min.js:26
jhereg/:1 Error handling response: TypeError: Cannot read properties of undefined (reading 'takeRecords')
    at Function.e.closeListeners (chrome-extension://clmkdohmabikagpnhjmgacbclihgmdje/content-script.js:1:5858)
    at chrome-extension://clmkdohmabikagpnhjmgacbclihgmdje/content-script.js:1:3858
client.js?locale=en&v=fw5fxy:100 Uncaught TypeError: Failed to construct 'URL': Invalid URL
    at getTrackerHost (client.js?locale=en&v=fw5fxy:100)
    at Object.onSuccess (client.js?locale=en&v=fw5fxy:627)
    at Object.<anonymous> (MooTools-Core-1.6.0-compat-compressed.js:5)
    at Array.forEach (<anonymous>)
    at Function.forEach (MooTools-Core-1.6.0-compat-compressed.js:5)
    at Array.each (MooTools-Core-1.6.0-compat-compressed.js:5)
    at Object.fireEvent (MooTools-Core-1.6.0-compat-compressed.js:5)
    at Object.r.extend.$owner (MooTools-Core-1.6.0-compat-compressed.js:5)
    at Object.onSuccess (MooTools-Core-1.6.0-compat-compressed.js:7)
    at Object.r.extend.$owner (MooTools-Core-1.6.0-compat-compressed.js:5)
getTrackerHost @ client.js?locale=en&v=fw5fxy:100
onSuccess @ client.js?locale=en&v=fw5fxy:627
(anonymous) @ MooTools-Core-1.6.0-compat-compressed.js:5
(anonymous) @ MooTools-Core-1.6.0-compat-compressed.js:5
each @ MooTools-Core-1.6.0-compat-compressed.js:5
fireEvent @ MooTools-Core-1.6.0-compat-compressed.js:5
r.extend.$owner @ MooTools-Core-1.6.0-compat-compressed.js:5
onSuccess @ MooTools-Core-1.6.0-compat-compressed.js:7
r.extend.$owner @ MooTools-Core-1.6.0-compat-compressed.js:5
success @ MooTools-Core-1.6.0-compat-compressed.js:7
r.extend.$owner @ MooTools-Core-1.6.0-compat-compressed.js:5
onStateChange @ MooTools-Core-1.6.0-compat-compressed.js:7
r.extend.$owner @ MooTools-Core-1.6.0-compat-compressed.js:5
(anonymous) @ MooTools-Core-1.6.0-compat-compressed.js:5
XMLHttpRequest.send (async)
send @ MooTools-Core-1.6.0-compat-compressed.js:7
r.extend.$owner @ MooTools-Core-1.6.0-compat-compressed.js:5
syncMainData @ client.js?locale=en&v=fw5fxy:700
(anonymous) @ MooTools-Core-1.6.0-compat-compressed.js:5
setTimeout (async)
delay @ MooTools-Core-1.6.0-compat-compressed.js:5
syncData @ client.js?locale=en&v=fw5fxy:711
updateMainData @ client.js?locale=en&v=fw5fxy:705
onContentLoaded @ client.js?locale=en&v=fw5fxy:1029
(anonymous) @ MooTools-Core-1.6.0-compat-compressed.js:5
(anonymous) @ MooTools-Core-1.6.0-compat-compressed.js:5
each @ MooTools-Core-1.6.0-compat-compressed.js:5
fireEvent @ MooTools-Core-1.6.0-compat-compressed.js:5
r.extend.$owner @ MooTools-Core-1.6.0-compat-compressed.js:5
args.onContentLoaded @ mocha.min.js:26
(anonymous) @ mocha.min.js:26
(anonymous) @ MooTools-Core-1.6.0-compat-compressed.js:5
(anonymous) @ MooTools-Core-1.6.0-compat-compressed.js:5
(anonymous) @ MooTools-Core-1.6.0-compat-compressed.js:5
each @ MooTools-Core-1.6.0-compat-compressed.js:5
fireEvent @ MooTools-Core-1.6.0-compat-compressed.js:5
r.extend.$owner @ MooTools-Core-1.6.0-compat-compressed.js:5
onSuccess @ MooTools-Core-1.6.0-compat-compressed.js:7
r.extend.$owner @ MooTools-Core-1.6.0-compat-compressed.js:5
success @ MooTools-Core-1.6.0-compat-compressed.js:7
r.extend.$owner @ MooTools-Core-1.6.0-compat-compressed.js:5
onStateChange @ MooTools-Core-1.6.0-compat-compressed.js:7
r.extend.$owner @ MooTools-Core-1.6.0-compat-compressed.js:5
(anonymous) @ MooTools-Core-1.6.0-compat-compressed.js:5
XMLHttpRequest.send (async)
send @ MooTools-Core-1.6.0-compat-compressed.js:7
r.extend.$owner @ MooTools-Core-1.6.0-compat-compressed.js:5
updateContentXHR @ mocha.min.js:26
loadSelect @ mocha.min.js:26
updateContent @ mocha.min.js:26
newPanel @ mocha.min.js:26
r.extend.$owner @ MooTools-Core-1.6.0-compat-compressed.js:5
initialize @ mocha.min.js:26
(anonymous) @ MooTools-More-1.6.0-compat-compressed.js:5
r.extend.$owner @ MooTools-Core-1.6.0-compat-compressed.js:5
(anonymous) @ MooTools-Core-1.6.0-compat-compressed.js:5
(anonymous) @ client.js?locale=en&v=fw5fxy:1015
s @ MooTools-Core-1.6.0-compat-compressed.js:6
a @ MooTools-Core-1.6.0-compat-compressed.js:6
load (async)
addListener @ MooTools-Core-1.6.0-compat-compressed.js:6
addEvent @ MooTools-Core-1.6.0-compat-compressed.js:6
(anonymous) @ MooTools-Core-1.6.0-compat-compressed.js:7
addEvent @ MooTools-More-1.6.0-compat-compressed.js:6
(anonymous) @ client.js?locale=en&v=fw5fxy:126

All of this doesn't tell me much except that I don't know any javascript. Hopefully this will tell someone something.
Post Reply